Bug #17849: ISAPI-version fails to load on 2.0.39

From: Date: Wed, 19 Jun 2002 18:23:28 +0000
Subject: Bug #17849: ISAPI-version fails to load on 2.0.39
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-11440@lists.php.net to get a copy of this message
From: Kristian.Bergmann@nvg.org Operating system: Windows XP PHP version: 4.2.1 PHP Bug Type: Apache2 related Bug description: ISAPI-version fails to load on 2.0.39 When trying to load the sapi\php4apache2.dll under Apache 2.0.39, I recieve the following error: Apache.exe -t Apache.exe: module "c:\php4build\snap\sapi\apache2filter\sapi_apache2.c" is not compatible with this version of Apache. Please contact the vendor for the correct version. The CGI-version runs fine, while the .36 runs the SAPI just fine, indicating that the changes the Apache-crew made to sapi is incompatible with this dll. Furthermore, the PHP-install (for Apache 1.3.x) says to use AddModule mod_php4.c. This failed under .36, so I would also suggest you include a segment on Apache2. -- Edit bug report at http://bugs.php.net/?id=17849&edit=1 -- Fixed in CVS: http://bugs.php.net/fix.php?id=17849&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=17849&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=17849&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=17849&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=17849&r=support Expected behavior: http://bugs.php.net/fix.php?id=17849&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=17849&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=17849&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=17849&r=globals

« previous php.bugs (#11440) next »