Bug #17849 Updated: ISAPI-version fails to load on 2.0.39

From: Date: Wed, 19 Jun 2002 18:49:57 +0000
Subject: Bug #17849 Updated: ISAPI-version fails to load on 2.0.39
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-11449@lists.php.net to get a copy of this message
ID: 17849 Updated by: Kristian.Bergmann@nvg.org Reported By: Kristian.Bergmann@nvg.org Status: Bogus Bug Type: Apache2 related Operating System: Windows XP PHP Version: 4.2.1 New Comment: Actually, that notice wasn't there when I initially reported the bug, so no need to yell at me. ;) Previous Comments: ------------------------------------------------------------------------ [2002-06-19 14:43:05] Kristian.Bergmann@nvg.org A thousand pardons. ------------------------------------------------------------------------ [2002-06-19 14:39:58] mfischer@php.net He was refering to http://bugs.php.net/report.php: "PLEASE DO NOT REPORT BUGS ABOUT PHP NOT WORKING WITH APACHE 2.0.39!!! THIS IS FIXED IN CVS AND YOU CAN TRY THE LATEST SNAPSHOT FROM HERE" Where "HERE" -> http://snaps.php.net/php4-latest.tar.bz2 ------------------------------------------------------------------------ [2002-06-19 14:35:56] Kristian.Bergmann@nvg.org Obviously. Care to elaborate or do you get a certain kick out of that Oracleish attitude? :p ------------------------------------------------------------------------ [2002-06-19 14:25:45] derick@php.net I guess reading is quite hard for you guys. ------------------------------------------------------------------------ [2002-06-19 14:23:27] Kristian.Bergmann@nvg.org When trying to load the sapi\php4apache2.dll under Apache 2.0.39, I recieve the following error: Apache.exe -t Apache.exe: module "c:\php4build\snap\sapi\apache2filter\sapi_apache2.c" is not compatible with this version of Apache. Please contact the vendor for the correct version. The CGI-version runs fine, while the .36 runs the SAPI just fine, indicating that the changes the Apache-crew made to sapi is incompatible with this dll. Furthermore, the PHP-install (for Apache 1.3.x) says to use AddModule mod_php4.c. This failed under .36, so I would also suggest you include a segment on Apache2. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=17849&edit=1

« previous php.bugs (#11449) next »