Bug #17930 Updated: problem when apache serving a php page that reside on the network

From: Date: Sun, 23 Jun 2002 14:32:30 +0000
Subject: Bug #17930 Updated: problem when apache serving a php page that reside on the network
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-11839@lists.php.net to get a copy of this message
ID: 17930 Updated by: HummerX123@hotmail.com Reported By: HummerX123@hotmail.com Status: Bogus Bug Type: Apache related Operating System: Win2k PHP Version: 4.2.1 New Comment: Something else that I might add is that the page that it failed to open is the page that i am serving for example when I am hitting http://localhost/test.php then the following error will be throw: Warning: Failed opening '//machinename/webroot/test.php' for inclusion (include_path='.;c:\php4\pear') in Unknown on line 0 where webroot is a network share folder. So basically the error said it fail to open itself..... However if test is a static html page then it work fine so I am sure that I don't have a problem with the configuration of Apache or windows. Previous Comments: ------------------------------------------------------------------------ [2002-06-23 06:40:36] sander@php.net I think you should not use network shares in your document root. I'm sure that this is not a problem in PHP, but a (configuration) problem in Apache or Windows. ------------------------------------------------------------------------ [2002-06-23 04:20:19] HummerX123@hotmail.com I am running Apache 1.3 on Windows 2000 and I got everything working fine when serving a test php script that is reside on the local machine. However I am starting to have all kind of weird error when Apache is serving a php page locate on a network. Please note that Apache still serving static html page just fine so there is no problem with the permission. When I use the php module version for apache the follow error occur: Warning: Failed opening 'pathtophppape' for inclusion (include_path='.;c:\php4\pear') in Unknown on line 0 Where 'pathtophppage' is something like '//machinename/webroot/phptest.php' When I use the cgi version then Apache will throw a Internal Server Error If anyone have any through on this pls let me know. Thanks ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=17930&edit=1

« previous php.bugs (#11839) next »