#44375 [Opn]: LDAP extension load failed
| From: | felipe@php.net | Date: | Mon, 10 Mar 2008 12:01:32 +0000 |
| Subject: | #44375 [Opn]: LDAP extension load failed | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-123128@lists.php.net to get a copy of this message | ||
ID: 44375
Updated by: felipe@php.net
Reported By: petr at hroch dot info
Status: Open
Bug Type: LDAP related
Operating System: Linux Debian Etch 4.0
PHP Version: 5.3CVS-2008-03-08 (CVS)
New Comment:
Odd... Compile with success here.
Previous Comments:
------------------------------------------------------------------------
[2008-03-10 09:19:20] petr at hroch dot info
Hi,
problem still remains.
Compiled PHP from source http://snaps.php.net/php5.3-latest.tar.gz
php -m
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/local/php/lib/php/extensions/ldap.so' -
/usr/local/php/lib/php/extensions/ldap.so: undefined symbol:
third_arg_force_ref in Unknown on line 0
[PHP Modules]
calendar
ctype
date
dom
ereg
filter
hash
iconv
json
libxml
openssl
pcntl
pcre
PDO
pdo_sqlite
posix
Reflection
session
SimpleXML
sockets
SPL
SQLite
standard
sysvmsg
sysvsem
sysvshm
tokenizer
xml
xmlreader
xmlwriter
zlib
[Zend Modules]
In PHP 5.2.5 everything works fine.
Regards
Petr
------------------------------------------------------------------------
[2008-03-09 21:38:15] petr at hroch dot info
I'll try it on Monday morning and let you know.
Thanks
Regards
Petr
------------------------------------------------------------------------
[2008-03-08 20:49:43] felipe@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5.3-latest.tar.gz
For Windows (zip):
http://snaps.php.net/win32/php5.3-win32-latest.zip
For Windows (installer):
http://snaps.php.net/win32/php5.3-win32-installer-latest.msi
Hello, with a new checkout it works fine for me.
------------------------------------------------------------------------
[2008-03-08 14:49:15] petr at hroch dot info
Correction for my previous post:
php -m
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/local/php/lib/php/extensions/ldap.so' -
/usr/local/php/lib/php/extensions/ldap.so: undefined symbol:
third_arg_force_ref in Unknown on line 0
------------------------------------------------------------------------
[2008-03-08 14:44:12] petr at hroch dot info
Description:
------------
LDAP extension load failed, compiled from latest cvs snapshot
Actual result:
--------------
php -m
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/local/php/lib/php/extensions/mbstring.so' -
/usr/local/php/lib/php/extensions/mbstring.so: undefined symbol:
second_arg_force_ref in Unknown on line 0
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=44375&edit=1