#44375 [Opn]: LDAP extension load failed
ID: 44375
User updated by: petr at hroch dot info
Reported By: petr at hroch dot info
Status: Open
Bug Type: LDAP related
Operating System: Linux Debian Etch 4.0
PHP Version: 5.3CVS-2008-03-08 (CVS)
New Comment:
I've found that this problem occures only if LDAP extension is compiled
externaly using phpize.
If it's compiled together with php core using general configure
script,
extension works fine.
I don't know where might be a problem.
Petr
Previous Comments:
------------------------------------------------------------------------
[2008-03-10 12:01:31] felipe@php.net
Odd... Compile with success here.
------------------------------------------------------------------------
[2008-03-10 09:19:20] petr at hroch dot info
Hi,
problem still remains.
Compiled PHP from source http://snaps.php.net/php5.3-latest.tar.gz
php -m
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/local/php/lib/php/extensions/ldap.so' -
/usr/local/php/lib/php/extensions/ldap.so: undefined symbol:
third_arg_force_ref in Unknown on line 0
[PHP Modules]
calendar
ctype
date
dom
ereg
filter
hash
iconv
json
libxml
openssl
pcntl
pcre
PDO
pdo_sqlite
posix
Reflection
session
SimpleXML
sockets
SPL
SQLite
standard
sysvmsg
sysvsem
sysvshm
tokenizer
xml
xmlreader
xmlwriter
zlib
[Zend Modules]
In PHP 5.2.5 everything works fine.
Regards
Petr
------------------------------------------------------------------------
[2008-03-09 21:38:15] petr at hroch dot info
I'll try it on Monday morning and let you know.
Thanks
Regards
Petr
------------------------------------------------------------------------
[2008-03-08 20:49:43] felipe@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5.3-latest.tar.gz
For Windows (zip):
http://snaps.php.net/win32/php5.3-win32-latest.zip
For Windows (installer):
http://snaps.php.net/win32/php5.3-win32-installer-latest.msi
Hello, with a new checkout it works fine for me.
------------------------------------------------------------------------
[2008-03-08 14:49:15] petr at hroch dot info
Correction for my previous post:
php -m
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/local/php/lib/php/extensions/ldap.so' -
/usr/local/php/lib/php/extensions/ldap.so: undefined symbol:
third_arg_force_ref in Unknown on line 0
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/44375
--
Edit this bug report at http://bugs.php.net/?id=44375&edit=1
Thread (10 messages)