#47485 [NEW]: HP Startup: Unable to load dynamic library
| From: | xywang at yahoo dot com | Date: | Tue, 24 Feb 2009 00:21:11 +0000 |
| Subject: | #47485 [NEW]: HP Startup: Unable to load dynamic library | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-134138@lists.php.net to get a copy of this message | ||
From: xywang at yahoo dot com
Operating system: XP
PHP version: 5.2.8
PHP Bug Type: Apache2 related
Bug description: HP Startup: Unable to load dynamic library
Description:
------------
I am seeing the same problem occurring in 5.2.8 windows install (PHP 5.2.8
installer [17,662Kb] - 08 December 2008)
The on start of apache I am seeing this message in apache error.log:
PHP Warning: PHP Startup: Unable to load dynamic library
'C:\\Path\\to\\PHP\\ext\\php_msql.dll' - The specified procedure could not
be found.\r\n in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library
'C:\\Path\\to\\PHP\\ext\\php_mysql.dll' - The specified procedure could no
t be found.\r\n in Unknown on line 0
...
...
I have tried "php5ts.dll into c:\windows\system32 and reboot", no luck.
I have tried to correct Windows ENV PHPRC to C:/Path/to/PHP/, no luck.
I have tried to set PHPIniDir to C:/Path/to/PHP/, also no luck.
Any clue? I like to re-open this bug and see if there is a solution to it.
Thanks.
--
Edit bug report at http://bugs.php.net/?id=47485&edit=1
--
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=47485&r=trysnapshot52
Try a CVS snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=47485&r=trysnapshot53
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=47485&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=47485&r=fixedcvs
Fixed in CVS and need be documented: http://bugs.php.net/fix.php?id=47485&r=needdocs
Fixed in release: http://bugs.php.net/fix.php?id=47485&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=47485&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=47485&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=47485&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=47485&r=support
Expected behavior: http://bugs.php.net/fix.php?id=47485&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=47485&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=47485&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=47485&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=47485&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=47485&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=47485&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=47485&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=47485&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=47485&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=47485&r=mysqlcfg