#18698 [Opn->Bgs]: symbol ssl_onceonlyinit: referenced symbol not found

From: Date: Fri, 02 Aug 2002 11:42:00 +0000
Subject: #18698 [Opn->Bgs]: symbol ssl_onceonlyinit: referenced symbol not found
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-15804@lists.php.net to get a copy of this message
ID: 18698 Updated by: sander@php.net Reported By: michel.jansens@ulb.ac.be -Status: Open +Status: Bogus Bug Type: Dynamic loading Operating System: Solaris 8 PHP Version: 4.2.2 New Comment: Your configure line is wrong. --with-open-ssl=/usr/local/ssl0.9.6.e \ ^ it should be --with-openssl=... Previous Comments: ------------------------------------------------------------------------ [2002-08-02 05:46:29] michel.jansens@ulb.ac.be I get an linking error when starting apache (DSO compiled): Syntax error on line 231 of /usr/products/apache_httpdevb/conf/httpd.conf: Cannot load /usr/products/apache_httpdevb/libexec/libphp4.so into server: ld.so.1: /usr/products/apache_httpdevb/bin/httpd: fatal: relocation error: file /usr/products/apache_httpdevb/libexec/libphp4.so: symbol ssl_onceonlyinit: referenced symbol not found I've tried different versions of openssl without success. I've done the same on a newer build of Solaris (on another machine) and that one works fine... I compiled the libphp4.so module like this: setenv CC gcc configure --enable-track-vars \ --with-apxs=/usr/products/apache_httpdev/bin/apxs \ --with-imap=/usr/products/imap/imap-2000b \ --with-curl=/usr/products/curl\ --with-informix=/usr/products/informix \ --enable-discard-path \ --with-imap-ssl=/usr/local/ssl0.9.6.e \ --with-open-ssl=/usr/local/ssl0.9.6.e \ --enable-wddx ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=18698&edit=1

« previous php.bugs (#15804) next »