#18698 [Bgs]: symbol ssl_onceonlyinit: referenced symbol not found
| From: | michel dot jansens at ulb dot ac dot be | Date: | Fri, 02 Aug 2002 14:30:00 +0000 |
| Subject: | #18698 [Bgs]: symbol ssl_onceonlyinit: referenced symbol not found | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-15827@lists.php.net to get a copy of this message | ||
ID: 18698
User updated by: michel.jansens@ulb.ac.be
Reported By: michel.jansens@ulb.ac.be
Status: Bogus
Bug Type: Dynamic loading
Operating System: Solaris 8
PHP Version: 4.2.2
New Comment:
Oops.. you're right about --with-openssl
Trouble is... it still reports the same problem when staring up
apache.
BTW: I could do without these ssl lines but for some reason since
PHP4.1.x when I use option --with-imap in combination with --with-curl
the configuration always tells me I should add --with-imap-ssl
Configuring with imap ou curl alone doesn't give me this error.
Previous Comments:
------------------------------------------------------------------------
[2002-08-02 07:42:00] sander@php.net
Your configure line is wrong.
--with-open-ssl=/usr/local/ssl0.9.6.e \
^
it should be --with-openssl=...
------------------------------------------------------------------------
[2002-08-02 05:46:29] michel.jansens@ulb.ac.be
I get an linking error when starting apache (DSO compiled):
Syntax error on line 231 of
/usr/products/apache_httpdevb/conf/httpd.conf:
Cannot load /usr/products/apache_httpdevb/libexec/libphp4.so into
server: ld.so.1: /usr/products/apache_httpdevb/bin/httpd: fatal:
relocation error: file
/usr/products/apache_httpdevb/libexec/libphp4.so: symbol
ssl_onceonlyinit: referenced symbol not found
I've tried different versions of openssl without success.
I've done the same on a newer build of Solaris (on another machine) and
that one works fine...
I compiled the libphp4.so module like this:
setenv CC gcc
configure --enable-track-vars \
--with-apxs=/usr/products/apache_httpdev/bin/apxs \
--with-imap=/usr/products/imap/imap-2000b \
--with-curl=/usr/products/curl\
--with-informix=/usr/products/informix \
--enable-discard-path \
--with-imap-ssl=/usr/local/ssl0.9.6.e \
--with-open-ssl=/usr/local/ssl0.9.6.e \
--enable-wddx
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=18698&edit=1