#18698 [Fbk->Csd]: symbol ssl_onceonlyinit: referenced symbol not found

From: Date: Fri, 02 Aug 2002 23:06:30 +0000
Subject: #18698 [Fbk->Csd]: symbol ssl_onceonlyinit: referenced symbol not found
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-15876@lists.php.net to get a copy of this message
ID: 18698 Updated by: sniper@php.net Reported By: michel.jansens@ulb.ac.be -Status: Feedback +Status: Closed Bug Type: Compile Failure Operating System: Solaris 8 PHP Version: 4.2.2 New Comment: This bug has been fixed in CVS. You can grab a snapshot of the CVS version at http://snaps.php.net/. In case this was a documentation problem, the fix will show up soon at http://www.php.net/manual/. In case this was a PHP.net website problem, the change will show up on the PHP.net site and on the mirror sites. Thank you for the report, and for helping us make PHP better. And update your c-client too.. Previous Comments: ------------------------------------------------------------------------ [2002-08-02 10:56:58] sander@php.net Are you 100% sure that c-client has ssl support built in? ------------------------------------------------------------------------ [2002-08-02 10:51:05] michel.jansens@ulb.ac.be reopening this bug ------------------------------------------------------------------------ [2002-08-02 10:29:59] michel.jansens@ulb.ac.be Oops.. you're right about --with-openssl Trouble is... it still reports the same problem when staring up apache. BTW: I could do without these ssl lines but for some reason since PHP4.1.x when I use option --with-imap in combination with --with-curl the configuration always tells me I should add --with-imap-ssl Configuring with imap ou curl alone doesn't give me this error. ------------------------------------------------------------------------ [2002-08-02 07:42:00] sander@php.net Your configure line is wrong. --with-open-ssl=/usr/local/ssl0.9.6.e \ ^ it should be --with-openssl=... ------------------------------------------------------------------------ [2002-08-02 05:46:29] michel.jansens@ulb.ac.be I get an linking error when starting apache (DSO compiled): Syntax error on line 231 of /usr/products/apache_httpdevb/conf/httpd.conf: Cannot load /usr/products/apache_httpdevb/libexec/libphp4.so into server: ld.so.1: /usr/products/apache_httpdevb/bin/httpd: fatal: relocation error: file /usr/products/apache_httpdevb/libexec/libphp4.so: symbol ssl_onceonlyinit: referenced symbol not found I've tried different versions of openssl without success. I've done the same on a newer build of Solaris (on another machine) and that one works fine... I compiled the libphp4.so module like this: setenv CC gcc configure --enable-track-vars \ --with-apxs=/usr/products/apache_httpdev/bin/apxs \ --with-imap=/usr/products/imap/imap-2000b \ --with-curl=/usr/products/curl\ --with-informix=/usr/products/informix \ --enable-discard-path \ --with-imap-ssl=/usr/local/ssl0.9.6.e \ --with-open-ssl=/usr/local/ssl0.9.6.e \ --enable-wddx ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=18698&edit=1

« previous php.bugs (#15876) next »