Bug #54197 [Com]: [PATH=] sections incompatibility with user_ini.filename set to null

From: Date: Tue, 08 Mar 2011 18:43:05 +0000
Subject: Bug #54197 [Com]: [PATH=] sections incompatibility with user_ini.filename set to null
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-159311@lists.php.net to get a copy of this message
Edit report at http://bugs.php.net/bug.php?id=54197&edit=1

 ID:                 54197
 Comment by:         julientld at free dot fr
 Reported by:        julientld at free dot fr
 Summary:            [PATH=] sections incompatibility with
                     user_ini.filename set to null
 Status:             Feedback
 Type:               Bug
 Package:            PHP options/info functions
 Operating System:   Windows Server 2003 SP2
 PHP Version:        5.3.5
 Assigned To:        pajoye
 Block user comment: N
 Private report:     N

 New Comment:

IIS does not crash. It continues to serve static files. But all php
scripts return the HTTP 500 error.

There is nothing in the php log file.


Previous Comments:
------------------------------------------------------------------------
[2011-03-08 19:31:13] pajoye@php.net

What says the error log? Or is it actually a crash?

------------------------------------------------------------------------
[2011-03-08 19:25:07] julientld at free dot fr

Description:
------------
Hello,

My configuration :

Windows Server 2003 SP2
IIS 6.0
PHP 5.3.5 VC9 x86 NTS
FastCGI 1.5
WinCache 1.1

Same problem seen with IIS 5.1 under Windows XP SP3.

Test script:
---------------
In the php.ini file (production based) :


[PHP]

;I do not want users to set their own configuration file so I disable
the below option (set to null)
user_ini.filename =

;I want to set my own simple PATH sections like that
[PATH=D:/www/]
upload_max_filesize = 5M

Expected result:
----------------
I expect to get no error

Actual result:
--------------
But all the php script I open return the following :


FastCGI Error
The FastCGI Handler was unable to process the request. 
--------------------------------------------------------------------------------

Error Details:

•The FastCGI process exited unexpectedly
•Error Number: -1073741819 (0xc0000005).
•Error Description: Unknown Error
HTTP Error 500 - Server Error.
Internet Information Services (IIS)

I obtain no error if I remove the [PATH=] section or set a filename to
user_ini.filename


------------------------------------------------------------------------



-- 
Edit this bug report at http://bugs.php.net/bug.php?id=54197&edit=1


Thread (22 messages)

« previous php.bugs (#159311) next »