Edit report at https://bugs.php.net/bug.php?id=54197&edit=1
ID: 54197
Comment by: ab@php.net
Reported by: julientld at free dot fr
Summary: [PATH=] sections incompatibility with
user_ini.filename set to null
Status: Analyzed
Type: Bug
Package: PHP options/info functions
Operating System: Windows Server 2003 SP2
PHP Version: 5.3.5
Assigned To: ab
Block user comment: N
Private report: N
New Comment:
The bug was still in the 5.3 trunk, but it's section independent as there was an
attepmpt to free an uninitialized variable. The bug is windows only. With the
patch, putting
user_ini.filename =
outside the path section, both local and global values are null. Putting it into
the section only local value is null.
Previous Comments:
------------------------------------------------------------------------
[2012-03-01 10:23:10] ab@php.net
The following patch has been added/updated:
Patch Name: fix_unintialized_doc_root
Revision: 1330597390
URL: https://bugs.php.net/patch-display.php?bug=54197&patch=fix_unintialized_doc_root&revision=1330597390
------------------------------------------------------------------------
[2012-01-16 21:45:42] info at garrant dot com
I have the exact issue with PHP 5.3.9 running on Windows 2008 IIS7. When you try to uncomment
user_ini.filename = and use a PATH section, there is a FastCGI error and all PHP pages will fail. I
even tried adding open quotes and it still fails with user_ini.filename = "". I want to
disable so sites cannot user individual .ini files. How can we do this?
------------------------------------------------------------------------
[2011-03-09 13:22:14] pajoye@php.net
So let do it the hard way until I work on the initial problem.
------------------------------------------------------------------------
[2011-03-09 13:20:26] carsten_sttgt at gmx dot de
> which is different
No. My last example is exactly the first "Test Script" from julientld at free dot fr.
Just without comments.
------------------------------------------------------------------------
[2011-03-09 13:09:43] pajoye@php.net
I explicitly asked three times to open a new issue for this exact problem, which
is different (as in require different fix). Why do you insist to post this info
here? That's getting annoying.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=54197--
Edit this bug report at https://bugs.php.net/bug.php?id=54197&edit=1