Edit report at https://bugs.php.net/bug.php?id=54197&edit=1
ID: 54197
Updated by: ab@php.net
Reported by: julientld at free dot fr
Summary: [PATH=] sections incompatibility with
user_ini.filename set to null
-Status: Assigned
+Status: Analyzed
Type: Bug
Package: PHP options/info functions
Operating System: Windows Server 2003 SP2
PHP Version: 5.3.5
-Assigned To: pajoye
+Assigned To: ab
Block user comment: N
Private report: N
Previous Comments:
------------------------------------------------------------------------
[2012-01-16 21:45:42] info at garrant dot com
I have the exact issue with PHP 5.3.9 running on Windows 2008 IIS7. When you try to uncomment
user_ini.filename = and use a PATH section, there is a FastCGI error and all PHP pages will fail. I
even tried adding open quotes and it still fails with user_ini.filename = "". I want to
disable so sites cannot user individual .ini files. How can we do this?
------------------------------------------------------------------------
[2011-03-09 13:22:14] pajoye@php.net
So let do it the hard way until I work on the initial problem.
------------------------------------------------------------------------
[2011-03-09 13:20:26] carsten_sttgt at gmx dot de
> which is different
No. My last example is exactly the first "Test Script" from julientld at free dot fr.
Just without comments.
------------------------------------------------------------------------
[2011-03-09 13:09:43] pajoye@php.net
I explicitly asked three times to open a new issue for this exact problem, which
is different (as in require different fix). Why do you insist to post this info
here? That's getting annoying.
------------------------------------------------------------------------
[2011-03-09 13:04:43] carsten_sttgt at gmx dot de
Well, if this makes you happy:
php -v
PHP 5.3.6RC2 (cli) (built: Mar 3 2011 01:08:35)
Copyright (c) 1997-2011 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies
Adding this to "php.ini":
| user_ini.filename =
| [PATH=C:/Users/Public/Documents/htdocs/]
| upload_max_filesize = 5M
php-cgi -f "C:\Users\Public\Documents\htdocs\test.php"
--> Result crash.
(eec.14a4): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
eax=00000000 ebx=01d92cc8 ecx=00000005 edx=01d92c70 esi=01d92cc0 edi=4f3893f4
eip=5c7fc1d7 esp=009bd9bc ebp=01d942e0 iopl=0 nv up ei ng nz na po cy
cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00210283
php5ts!_zend_mm_free_int+0x57:
5c7fc1d7 8b0c37 mov ecx,dword ptr [edi+esi] ds:0023:5111c0b4=????????
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=54197--
Edit this bug report at https://bugs.php.net/bug.php?id=54197&edit=1