Bug #61295 [NEW]: php-fpm should not fail with commented 'user' for non-root start
| From: | sixd@php.net | Date: | Mon, 05 Mar 2012 22:37:23 +0000 |
| Subject: | Bug #61295 [NEW]: php-fpm should not fail with commented 'user' for non-root start | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-168178@lists.php.net to get a copy of this message | ||
From: sixd
Operating system: Linux
PHP version: 5.4.0
Package: FPM related
Bug Type: Bug
Bug description:php-fpm should not fail with commented 'user' for non-root start
Description:
------------
For non-root users:
1. if php-fpm.config has the default 'user = nobody' then php-fpm starts
with:
"WARNING: [pool www] 'user' directive is ignored when FPM is not
running as
root"
2. But if the 'user' directive is commented out then php-fpm fails
to start and gives "ALERT: [pool www] user has not been defined"
Php-fpm should not fail to start for non root users when 'user' (and
probably
'group') are commented out of php-fpm.conf
--
Edit bug report at https://bugs.php.net/bug.php?id=61295&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=61295&r=trysnapshot54
Try a snapshot (PHP 5.3): https://bugs.php.net/fix.php?id=61295&r=trysnapshot53
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=61295&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=61295&r=fixed
Fixed in SVN and need be documented: https://bugs.php.net/fix.php?id=61295&r=needdocs
Fixed in release: https://bugs.php.net/fix.php?id=61295&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=61295&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=61295&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=61295&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=61295&r=support
Expected behavior: https://bugs.php.net/fix.php?id=61295&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=61295&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=61295&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=61295&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=61295&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=61295&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=61295&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=61295&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=61295&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=61295&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=61295&r=mysqlcfg