Bug #61295 [Ana->Csd]: php-fpm should not fail with commented 'user' for non-root start

From: Date: Wed, 23 May 2012 09:32:35 +0000
Subject: Bug #61295 [Ana->Csd]: php-fpm should not fail with commented 'user' for non-root start
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-170707@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=61295&edit=1 ID: 61295 Updated by: fat@php.net Reported by: sixd@php.net Summary: php-fpm should not fail with commented 'user' for non-root start -Status: Analyzed +Status: Closed Type: Bug Package: FPM related Operating System: Linux PHP Version: 5.4.0 Assigned To: fat Block user comment: N Private report: N New Comment: This bug has been fixed in SVN. Snapshots of the sources are packaged every three hours; this change will be in the next snapshot. You can grab the snapshot at http://snaps.php.net/. For Windows: http://windows.php.net/snapshots/ Thank you for the report, and for helping us make PHP better. Previous Comments: ------------------------------------------------------------------------ [2012-05-23 09:32:16] fat@php.net Automatic comment on behalf of fat Revision: http://git.php.net/?p=php-src.git;a=commit;h=a07d76c0ba57e6471ac5869af0aaa26206baa284 Log: - Fixed bug #61295 (php-fpm should not fail with commented 'user' for non-root start) ------------------------------------------------------------------------ [2012-05-23 09:32:14] fat@php.net Automatic comment on behalf of fat Revision: http://git.php.net/?p=php-src.git;a=commit;h=812d2481935185eeeabb2c1fe2d7eafd76fc7359 Log: - Fixed bug #61295 (php-fpm should not fail with commented 'user' for non-root start) ------------------------------------------------------------------------ [2012-03-05 22:37:23] sixd@php.net Description: ------------ For non-root users: 1. if php-fpm.config has the default 'user = nobody' then php-fpm starts with: "WARNING: [pool www] 'user' directive is ignored when FPM is not running as root" 2. But if the 'user' directive is commented out then php-fpm fails to start and gives "ALERT: [pool www] user has not been defined" Php-fpm should not fail to start for non root users when 'user' (and probably 'group') are commented out of php-fpm.conf ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=61295&edit=1

« previous php.bugs (#170707) next »