Bug #61295 [Opn->Ana]: php-fpm should not fail with commented 'user' for non-root start
Edit report at https://bugs.php.net/bug.php?id=61295&edit=1
ID: 61295
Updated by: fat@php.net
Reported by: sixd@php.net
Summary: php-fpm should not fail with commented 'user' for
non-root start
-Status: Open
+Status: Analyzed
Type: Bug
Package: FPM related
Operating System: Linux
PHP Version: 5.4.0
-Assigned To:
+Assigned To: fat
Block user comment: N
Private report: N
Previous Comments:
------------------------------------------------------------------------
[2012-03-05 22:37:23] sixd@php.net
Description:
------------
For non-root users:
1. if php-fpm.config has the default 'user = nobody' then php-fpm starts with:
"WARNING: [pool www] 'user' directive is ignored when FPM is not running as
root"
2. But if the 'user' directive is commented out then php-fpm fails
to start and gives "ALERT: [pool www] user has not been defined"
Php-fpm should not fail to start for non root users when 'user' (and probably
'group') are commented out of php-fpm.conf
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=61295&edit=1
Thread (4 messages)