#19022 [Com]: PHP Warning: Failed to write session data (files)

From: Date: Tue, 27 Aug 2002 07:22:13 +0000
Subject: #19022 [Com]: PHP Warning: Failed to write session data (files)
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-17915@lists.php.net to get a copy of this message
ID: 19022 Comment by: m.heidenwolf@ehotel.ag Reported By: phpbugs@mx4k.com Status: Open Bug Type: Session related Operating System: linux (rh7.3), apache 1.3.26 PHP Version: 4.2.2 New Comment: hi, i have randomly the same problems. I have a Apache/1.3.26 with PHP Version 4.2.3-dev (23.8.2002) somebody reported that you can workaround this Problem with an shutdown_function wich makes an session_write_close but this is not the case as you see in the error_log; this is bugkiller.php The opposite way like reported here has no effect because before i had no register_shutdown_function. my error Log: [Tue Aug 27 08:47:12 2002] [error] PHP Warning: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp/) in /[...]/bugkiller.php on line 5 my php ini is standard. Previous Comments: ------------------------------------------------------------------------ [2002-08-25 20:21:18] rossr@reactive.com Hi, I've been having the same problem that you have been experiencing. You added a comment to my submission last week (Bug #19029) to setup error logging. I enabled the error logging after reading your post and I haven't been getting any or the errors that you have been getting but our users are still being logged out of the site. We are not using the "register_shutdown_function" which would explain why I haven't been getting the same error logs that you have been getting. PHP is running as the CGI version with Apache/1.3.19 (Unix) and the site has FrontPage/5.0.2.2510 extensions. ------------------------------------------------------------------------ [2002-08-23 06:15:30] phpbugs@mx4k.com hi, problem solved. still a bug in php. I was using "register_shutdown_function" to dump some info to a logfile. somehow it breaks the save_handler from session mod files. I removed the shutdown function and put the line into an auto append php file. Now my logfile is clean and by now i didnt get any strange session problems. ------------------------------------------------------------------------ [2002-08-22 07:16:31] phpbugs@mx4k.com . ------------------------------------------------------------------------ [2002-08-22 07:10:48] phpbugs@mx4k.com upgraded to 4.2.2 today .. still the same errors my configure: ./configure \ --with-apache=../apache_1.3.26 \ --with-pgsql=/opt/postgresql-7.2.1 kernel is 2.4.7-10, register_globals=On ------------------------------------------------------------------------ [2002-08-21 18:51:10] phpbugs@mx4k.com sorry, no. (believe me i wouldnt post here if i could find any reasons why my OS/Fs should screw up the files) FYI I have tried LOTS of stuff but this problem persists. [root@web1 root]# df Filesystem 1k-blocks Used Available Use% Mounted on /dev/hda5 49533868 19648360 27369332 42% / /dev/hda1 23302 1348 20751 7% /boot none 514452 0 514452 0% /dev/shm /dev/hda2 9288792 78404 8738480 1% /var /tmp is in / and have 27gig free space, should be enough. and as i said it doesnt lose all session data .. just a random (but too high) portion. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/19022 -- Edit this bug report at http://bugs.php.net/?id=19022&edit=1

« previous php.bugs (#17915) next »