#19022 [Com]: PHP Warning: Failed to write session data (files)
| From: | php at rjs3 dot com | Date: | Fri, 18 Apr 2003 14:01:35 +0000 |
| Subject: | #19022 [Com]: PHP Warning: Failed to write session data (files) | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-37847@lists.php.net to get a copy of this message | ||
ID: 19022
Comment by: php at rjs3 dot com
Reported By: phpbugs at mx4k dot com
Status: No Feedback
Bug Type: Session related
Operating System: linux (rh7.3), apache 1.3.26
PHP Version: 4.2.2
New Comment:
I have had this problem for a long time.
Thanks to the individual that mentioned the /var/www/tmp directory. I
did not change the permissions of the directory, I simply got rid of it
and the problem went away.
I used to have a /var/www/tmp from testing in the past. So I just
deleted it and the problem is solved.
PHP developers: Any reason why this would mess up PHP sessions?
Previous Comments:
------------------------------------------------------------------------
[2003-03-21 06:35:25] jsarac at fi dot uba dot ar
I was having similar problems. It seems to be related to the require()
statement.
I solved this putting the seesion_start() statement outside the
included script (e.g. if I have require("auth.php") I put
session_start() issue outside auth.php.
At least It works in my particular case. You can test it and see if it
works for you too.
Please post your results. I
------------------------------------------------------------------------
[2003-02-08 01:01:21] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
------------------------------------------------------------------------
[2003-01-30 03:52:32] cold80 at libero dot it
I HAVE SOLVED!!!
I created a tmp directory in /var/www that is my OpenBSD Apache root
directory (not document root). I set the right permissions and now it
runs!!!
Good luck guys!
------------------------------------------------------------------------
[2003-01-29 06:02:15] sniper@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
(can not reproduce anywhere)
------------------------------------------------------------------------
[2003-01-29 05:25:32] cold80 at libero dot it
I have a basic installation of OpenBSD 3.2, Qmail 1.03, Courier-IMAP
1.6.2, Apache 1.3.26, PHP 4.2.3. I have configured PHP and all seems
run. But, when I installed SquirrelMail 1.2.10 for webmail service, I
received the same error
Warning: open(/tmp/sess_7538b7739bdd44e2fb0e747f65af858d, O_RDWR)
failed: No such file or directory (2) in /htdocs/webmail/src/global.php
on line 134
and then
Warning: Failed to write session data (files). Please verify that the
current setting of session.save_path is correct (/tmp) in Unknown on
line 0
I think it is your same problem. I have also tried to write a simple
php file with only the row
<? session_open(); ?>
It returns the usual error! I hope there will be a solution as soon as
possible, I'm very sad to see all run but I can't install my Squirrel
WebMail...
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/19022
--
Edit this bug report at http://bugs.php.net/?id=19022&edit=1