#19022 [Com]: PHP Warning: Failed to write session data (files)

From: Date: Tue, 27 Aug 2002 10:08:14 +0000
Subject: #19022 [Com]: PHP Warning: Failed to write session data (files)
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-17927@lists.php.net to get a copy of this message
 ID:               19022
 Comment by:       phpbugs@mx4k.com
 Reported By:      phpbugs@mx4k.com
 Status:           Open
 Bug Type:         Session related
 Operating System: linux (rh7.3), apache 1.3.26
 PHP Version:      4.2.2
 New Comment:

hi,

the problem returned. it doesnt seem to be affected by
register_shutdown_function. the day i thought the problem was gone was
related to a problem at our ISP (which caused very low traffic (5k
instead of 70k users))

maybe its just a problem under high load or something like that. im
back at the old problem (tried apache+php rpm (with dso), same
problem).


Previous Comments:
------------------------------------------------------------------------

[2002-08-27 03:22:12] m.heidenwolf@ehotel.ag

hi,

i have randomly the same problems.
I have a Apache/1.3.26 with PHP Version 4.2.3-dev (23.8.2002)
somebody reported that you can workaround this Problem with an
shutdown_function wich makes an session_write_close but this is not the
case as you see in the error_log; this is bugkiller.php The opposite
way like reported here has no effect because before i had no
register_shutdown_function.

my error Log:
[Tue Aug 27 08:47:12 2002] [error] PHP Warning:  Failed to write
session data (files). Please verify that the current setting of
session.save_path is correct (/tmp/) in /[...]/bugkiller.php on line 5

my php ini is standard.

------------------------------------------------------------------------

[2002-08-25 20:21:18] rossr@reactive.com

Hi,

I've been having the same problem that you have been experiencing. You
added a comment to my submission last week (Bug #19029) to setup error
logging.

I enabled the error logging after reading your post and I haven't been
getting any or the errors that you have been getting but our users are
still being logged out of the site.

We are not using the "register_shutdown_function" which would explain
why I haven't been getting the same error logs that you have been
getting.

PHP is running as the CGI version with Apache/1.3.19 (Unix) and the
site has FrontPage/5.0.2.2510 extensions.

------------------------------------------------------------------------

[2002-08-23 06:15:30] phpbugs@mx4k.com

hi,

problem solved.

still a bug in php.

I was using "register_shutdown_function" to dump some info to a
logfile. somehow it breaks the save_handler from session mod files. I
removed the shutdown function and put the line into an auto append php
file. Now my logfile is clean and by now i didnt get any strange
session problems.

------------------------------------------------------------------------

[2002-08-22 07:16:31] phpbugs@mx4k.com

.

------------------------------------------------------------------------

[2002-08-22 07:10:48] phpbugs@mx4k.com

upgraded to 4.2.2 today .. still the same errors

my configure:

./configure \
--with-apache=../apache_1.3.26 \
--with-pgsql=/opt/postgresql-7.2.1

kernel is 2.4.7-10, register_globals=On

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
    http://bugs.php.net/19022

-- 
Edit this bug report at http://bugs.php.net/?id=19022&edit=1



Thread (75 messages)

« previous php.bugs (#17927) next »