Req #65078 [NEW]: opcache not enabled in embedded sapi / uwsgi

From: Date: Fri, 21 Jun 2013 00:15:24 +0000
Subject: Req #65078 [NEW]: opcache not enabled in embedded sapi / uwsgi
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-179660@lists.php.net to get a copy of this message
From:             info at icod dot de
Operating system: linux 3.9.6
PHP version:      5.5.0
Package:          opcache
Bug Type:         Feature/Change Request
Bug description:opcache not enabled in embedded sapi / uwsgi

Description:
------------
Startup Failed 	Opcode Caching is only supported in Apache, ISAPI, FPM and
FastCGI SAPIs 

uwsgi (my version 1.9.12)
http://projects.unbit.it/uwsgi/
uses the embed sapi to compile a php plugin
you can build plugins with different versions of php, good stuff.

you can use apc in php-5.4, one could use apc in php-5.5 but why?

the opcode cache is disabled because uwsgi is using the embedded sapi to
build the plugin.

Test script:
---------------
<?php phpinfo(); ?>


Expected result:
----------------
Opcode Caching 	Enabled
Optimization 	Enabled

Actual result:
--------------
Opcode Caching 	Disabled
Optimization 	Disabled 
Startup Failed 	Opcode Caching is only supported in Apache, ISAPI, FPM and
FastCGI SAPIs 

-- 
Edit bug report at https://bugs.php.net/bug.php?id=65078&edit=1
-- 
Try a snapshot (PHP 5.4):   https://bugs.php.net/fix.php?id=65078&r=trysnapshot54
Try a snapshot (PHP 5.3):   https://bugs.php.net/fix.php?id=65078&r=trysnapshot53
Try a snapshot (trunk):     https://bugs.php.net/fix.php?id=65078&r=trysnapshottrunk
Fixed in SVN:               https://bugs.php.net/fix.php?id=65078&r=fixed
Fixed in release:           https://bugs.php.net/fix.php?id=65078&r=alreadyfixed
Need backtrace:             https://bugs.php.net/fix.php?id=65078&r=needtrace
Need Reproduce Script:      https://bugs.php.net/fix.php?id=65078&r=needscript
Try newer version:          https://bugs.php.net/fix.php?id=65078&r=oldversion
Not developer issue:        https://bugs.php.net/fix.php?id=65078&r=support
Expected behavior:          https://bugs.php.net/fix.php?id=65078&r=notwrong
Not enough info:            https://bugs.php.net/fix.php?id=65078&r=notenoughinfo
Submitted twice:            https://bugs.php.net/fix.php?id=65078&r=submittedtwice
register_globals:           https://bugs.php.net/fix.php?id=65078&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=65078&r=php4
Daylight Savings:           https://bugs.php.net/fix.php?id=65078&r=dst
IIS Stability:              https://bugs.php.net/fix.php?id=65078&r=isapi
Install GNU Sed:            https://bugs.php.net/fix.php?id=65078&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=65078&r=float
No Zend Extensions:         https://bugs.php.net/fix.php?id=65078&r=nozend
MySQL Configuration Error:  https://bugs.php.net/fix.php?id=65078&r=mysqlcfg



Thread (9 messages)

« previous php.bugs (#179660) next »