Req #65078 [Opn]: opcache not enabled in embedded sapi / uwsgi
Edit report at https://bugs.php.net/bug.php?id=65078&edit=1
ID: 65078
User updated by: info at icod dot de
Reported by: info at icod dot de
Summary: opcache not enabled in embedded sapi / uwsgi
Status: Open
Type: Feature/Change Request
Package: opcache
Operating System: linux 3.9.6
PHP Version: 5.5.0
Block user comment: N
Private report: N
New Comment:
Server API uWSGI/php
Previous Comments:
------------------------------------------------------------------------
[2013-06-21 00:15:24] info at icod dot de
Description:
------------
Startup Failed Opcode Caching is only supported in Apache, ISAPI, FPM and FastCGI SAPIs
uwsgi (my version 1.9.12)
http://projects.unbit.it/uwsgi/
uses the embed sapi to compile a php plugin
you can build plugins with different versions of php, good stuff.
you can use apc in php-5.4, one could use apc in php-5.5 but why?
the opcode cache is disabled because uwsgi is using the embedded sapi to build the plugin.
Test script:
---------------
<?php phpinfo(); ?>
Expected result:
----------------
Opcode Caching Enabled
Optimization Enabled
Actual result:
--------------
Opcode Caching Disabled
Optimization Disabled
Startup Failed Opcode Caching is only supported in Apache, ISAPI, FPM and FastCGI SAPIs
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=65078&edit=1
Thread (9 messages)