Req #65078 [Opn]: opcache not enabled in embedded sapi / uwsgi
| From: | sixd@php.net | Date: | Fri, 21 Jun 2013 21:53:04 +0000 |
| Subject: | Req #65078 [Opn]: opcache not enabled in embedded sapi / uwsgi | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-179681@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=65078&edit=1
ID: 65078
Updated by: sixd@php.net
Reported by: info at icod dot de
Summary: opcache not enabled in embedded sapi / uwsgi
Status: Open
Type: Feature/Change Request
Package: opcache
Operating System: linux 3.9.6
PHP Version: 5.5.0
Block user comment: N
Private report: N
New Comment:
You might want to get involved in this project:
http://news.php.net/php.internals/67768
Previous Comments:
------------------------------------------------------------------------
[2013-06-21 00:17:02] info at icod dot de
Server API uWSGI/php
------------------------------------------------------------------------
[2013-06-21 00:15:24] info at icod dot de
Description:
------------
Startup Failed Opcode Caching is only supported in Apache, ISAPI, FPM and FastCGI SAPIs
uwsgi (my version 1.9.12)
http://projects.unbit.it/uwsgi/
uses the embed sapi to compile a php plugin
you can build plugins with different versions of php, good stuff.
you can use apc in php-5.4, one could use apc in php-5.5 but why?
the opcode cache is disabled because uwsgi is using the embedded sapi to build the plugin.
Test script:
---------------
<?php phpinfo(); ?>
Expected result:
----------------
Opcode Caching Enabled
Optimization Enabled
Actual result:
--------------
Opcode Caching Disabled
Optimization Disabled
Startup Failed Opcode Caching is only supported in Apache, ISAPI, FPM and FastCGI SAPIs
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=65078&edit=1