Bug #69233 [Com]: PHP-CGI.EXE and OPCache crash with error code 0xc0000005

From: Date: Tue, 24 Mar 2015 17:01:51 +0000
Subject: Bug #69233 [Com]: PHP-CGI.EXE and OPCache crash with error code 0xc0000005
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-191573@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=69233&edit=1

 ID:                 69233
 Comment by:         julientld at free dot fr
 Reported by:        julientld at free dot fr
 Summary:            PHP-CGI.EXE and OPCache crash with error code
                     0xc0000005
 Status:             Open
 Type:               Bug
 Package:            opcache
 Operating System:   Windows Server 2012
 PHP Version:        5.6.7RC1
 Block user comment: N
 Private report:     N

 New Comment:

Yes, I have seen your bug report #69067. I hope someone from the dev team will give us soon infos
about that.


Previous Comments:
------------------------------------------------------------------------
[2015-03-24 16:51:27] deivid dot garcia dot garcia at gmail dot com

I reported something similar in another PHP issue:

https://bugs.php.net/bug.php?id=69067

Opcode cache is failing intermitently on windows systems.

There is a chance that these issues are not related to a specific script but to zend engine not
properly managing things under tough conditions (at least in windows) such as forecefully shtudown
processes or high memory pressure.

------------------------------------------------------------------------
[2015-03-22 09:36:52] julientld at free dot fr

Hello,

Before suspending this bug, perhaps someone could answer my last comment ? The bug is absolutely not
solved. Strange practice to investigate a bug.

Has anybody from the OPCache team studied the supplied backtrace ? I don't see what additional
feedback I can give you as explained.

Thanks.

------------------------------------------------------------------------
[2015-03-22 04:22:19] php-bugs at lists dot php dot net

No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.

------------------------------------------------------------------------
[2015-03-13 07:55:58] julientld at free dot fr

Hello,

Thank you for your fast answer.

Ufortunately, I can't provide you a script as I don't have any error in the php log file
when this issue occurs.

When the server reboots and when the php-cgi.exe processes are "killed", there are
potentially hundreds of php scripts which could be in progress. I can't believe, each month for
a year and a half this is exactly the same script which is running when the server reboots.

I don't think this error is related to a script or a function in particular but this is rather
a problem for managing brutal shutdowns of the processes.

The backtrace is not sufficient to investigate this problem ?

Thanks.

Julien

------------------------------------------------------------------------
[2015-03-13 06:58:41] laruence@php.net

Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc. If the script requires a 
database to demonstrate the issue, please make sure it creates 
all necessary tables, stored procedures etc.

Please avoid embedding huge scripts into the report.



------------------------------------------------------------------------


The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at

    https://bugs.php.net/bug.php?id=69233


--
Edit this bug report at https://bugs.php.net/bug.php?id=69233&edit=1


Thread (19 messages)

« previous php.bugs (#191573) next »