Bug #69233 [Com]: PHP-CGI.EXE and OPCache crash with error code 0xc0000005

From: Date: Sat, 26 Nov 2016 23:14:17 +0000
Subject: Bug #69233 [Com]: PHP-CGI.EXE and OPCache crash with error code 0xc0000005
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-205654@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=69233&edit=1 ID: 69233 Comment by: ricardolpinto at gmail dot com Reported by: julientld at free dot fr Summary: PHP-CGI.EXE and OPCache crash with error code 0xc0000005 Status: Open Type: Bug Package: opcache Operating System: Windows Server 2012 PHP Version: 7.0.1 Block user comment: N Private report: N New Comment: Same error on windows server 2012, several error during the day Log Name: Application Source: Application Error Date: 24/11/2016 09:42:17 Event ID: 1000 Task Category: (100) Level: Error Keywords: Classic User: N/A Computer: multcloud Description: Faulting application name: php-cgi.exe, version: 7.0.12.0, time stamp: 0x57ffc9c3 Faulting module name: php_opcache.dll, version: 7.0.12.0, time stamp: 0x57ffd1ce Exception code: 0xc0000005 Fault offset: 0x0000000000006db9 Faulting process id: 0x3d10 Faulting application start time: 0x01d24647ce7c8cb6 Faulting application path: C:\MultServer\php7012\php-cgi.exe Faulting module path: C:\MultServer\php7012\ext\php_opcache.dll Report Id: 0c4a6d83-b23b-11e6-80fe-001c42a7f7cf Faulting package full name: Faulting package-relative application ID: Event Xml: <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"> <System> <Provider Name="Application Error" /> <EventID Qualifiers="0">1000</EventID> <Level>2</Level> <Task>100</Task> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2016-11-24T11:42:17.000000000Z" /> <EventRecordID>141222</EventRecordID> <Channel>Application</Channel> <Computer>multcloud</Computer> <Security /> </System> <EventData> <Data>php-cgi.exe</Data> <Data>7.0.12.0</Data> <Data>57ffc9c3</Data> <Data>php_opcache.dll</Data> <Data>7.0.12.0</Data> <Data>57ffd1ce</Data> <Data>c0000005</Data> <Data>0000000000006db9</Data> <Data>3d10</Data> <Data>01d24647ce7c8cb6</Data> <Data>C:\MultServer\php7012\php-cgi.exe</Data> <Data>C:\MultServer\php7012\ext\php_opcache.dll</Data> <Data>0c4a6d83-b23b-11e6-80fe-001c42a7f7cf</Data> <Data> </Data> <Data> </Data> </EventData> </Event> Previous Comments: ------------------------------------------------------------------------ [2016-01-28 09:09:25] julientld at free dot fr PHP 7.0.1 also concerned. PHP Version updated in the bug details. ------------------------------------------------------------------------ [2016-01-28 09:06:41] julientld at free dot fr Hello, In fact not, the OPcache errors in the Windows Event Viewer are not yet solved despite PHP 7. I have had the following two below errors on the 2016/01/16. The server configuration : Windows Server 2012 IIS 8.0 PHP 7.0.1 NTS VC14 x64 (now 7.0.2) MySQL 5.6.21 WinCache 2.0.0.4 I have a dump file corresponding to these errors if you want finally to investigate this bug... Nom de l’application défaillante php-cgi.exe, version : 7.0.1.0, horodatage : 0x5671dbae Nom du module défaillant : php_opcache.dll, version : 7.0.1.0, horodatage : 0x5671e09f Code d’exception : 0xc0000005 Décalage d’erreur : 0x0000000000008d7d ID du processus défaillant : 0x12c0 Heure de début de l’application défaillante : 0x01d150a8b7d531b0 Chemin d’accès de l’application défaillante : C:\php\php-cgi.exe Chemin d’accès du module défaillant: C:\php\ext\php_opcache.dll ID de rapport : f59bf806-bc9b-11e5-941e-90b11c2fa6ed Nom complet du package défaillant : ID de l’application relative au package défaillant : and La description de l’ID d’événement 487 dans la source Zend OPcache est introuvable. Le composant qui a déclenché cet événement n’est pas installé sur l’ordinateur local ou l’installation est endommagée. Vous pouvez installer ou réparer le composant sur l’ordinateur local. Si l’événement provient d’un autre ordinateur, les informations d’affichage doivent être enregistrées avec l’événement. Les informations suivantes étaient incluses avec l’événement : Base address marks unusable memory region (fall-back to file cache) Tentative d’accès à une adresse non valide. ------------------------------------------------------------------------ [2015-12-14 19:44:43] julientld at free dot fr For me the OPCache crash when Windows reboots seems to be solved by PHP 7.0. FYI, I have set the opcache.file_cache option. Not tried without. Need more time to affirm definitely that the bug is 100 % fixed. ------------------------------------------------------------------------ [2015-05-14 15:59:14] quantuumsnot at gmail dot com The exact error: Unhandled exception at 0x000007FEEDE981BC (php_opcache.dll) in php-cgi.exe: 0xC0000094: Integer division by zero. ------------------------------------------------------------------------ [2015-05-13 16:58:07] quantuumsnot at gmail dot com To add some clarity - php is the thread-safe version ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at https://bugs.php.net/bug.php?id=69233 -- Edit this bug report at https://bugs.php.net/bug.php?id=69233&edit=1

« previous php.bugs (#205654) next »