Bug #69233 [Opn]: PHP-CGI.EXE and OPCache crash with error code 0xc0000005

From: Date: Thu, 28 Jan 2016 09:09:26 +0000
Subject: Bug #69233 [Opn]: PHP-CGI.EXE and OPCache crash with error code 0xc0000005
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-198938@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=69233&edit=1

 ID:                 69233
 User updated by:    julientld at free dot fr
 Reported by:        julientld at free dot fr
 Summary:            PHP-CGI.EXE and OPCache crash with error code
                     0xc0000005
 Status:             Open
 Type:               Bug
 Package:            opcache
 Operating System:   Windows Server 2012
-PHP Version:        5.6.7RC1
+PHP Version:        7.0.1
 Block user comment: N
 Private report:     N

 New Comment:

PHP 7.0.1 also concerned.
PHP Version updated in the bug details.


Previous Comments:
------------------------------------------------------------------------
[2016-01-28 09:06:41] julientld at free dot fr

Hello,

In fact not, the OPcache errors in the Windows Event Viewer are not yet solved despite PHP 7. I have
had the following two below errors on the 2016/01/16.

The server configuration :

Windows Server 2012
IIS 8.0
PHP 7.0.1 NTS VC14 x64 (now 7.0.2)
MySQL 5.6.21
WinCache 2.0.0.4

I have a dump file corresponding to these errors if you want finally to investigate this bug...







Nom de l’application défaillante php-cgi.exe, version : 7.0.1.0, horodatage : 0x5671dbae
Nom du module défaillant : php_opcache.dll, version : 7.0.1.0, horodatage : 0x5671e09f
Code d’exception : 0xc0000005
Décalage d’erreur : 0x0000000000008d7d
ID du processus défaillant : 0x12c0
Heure de début de l’application défaillante : 0x01d150a8b7d531b0
Chemin d’accès de l’application défaillante : C:\php\php-cgi.exe
Chemin d’accès du module défaillant: C:\php\ext\php_opcache.dll
ID de rapport : f59bf806-bc9b-11e5-941e-90b11c2fa6ed
Nom complet du package défaillant : 
ID de l’application relative au package défaillant : 



and



La description de l’ID d’événement 487 dans la source Zend OPcache est introuvable.
Le composant qui a déclenché 

cet événement n’est pas installé sur l’ordinateur local ou l’installation
est endommagée. Vous pouvez installer ou 

réparer le composant sur l’ordinateur local.

Si l’événement provient d’un autre ordinateur, les informations d’affichage
doivent être enregistrées avec 

l’événement.

Les informations suivantes étaient incluses avec l’événement : 

Base address marks unusable memory region (fall-back to file cache)
Tentative d’accès à une adresse non valide.

------------------------------------------------------------------------
[2015-12-14 19:44:43] julientld at free dot fr

For me the OPCache crash when Windows reboots seems to be solved by PHP 7.0. FYI, I have set the
opcache.file_cache option. Not tried without.

Need more time to affirm definitely that the bug is 100 % fixed.

------------------------------------------------------------------------
[2015-05-14 15:59:14] quantuumsnot at gmail dot com

The exact error:
Unhandled exception at 0x000007FEEDE981BC (php_opcache.dll) in php-cgi.exe: 0xC0000094: Integer
division by zero.

------------------------------------------------------------------------
[2015-05-13 16:58:07] quantuumsnot at gmail dot com

To add some clarity - php is the thread-safe version

------------------------------------------------------------------------
[2015-05-13 16:55:59] quantuumsnot at gmail dot com

Same issue under Windows 7 x64 and php-5.6.8-Win32-VC11-x64

Disabling the whole extension dll solves it.

opcache.enable_cli=0 doesn't help

------------------------------------------------------------------------


The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at

    https://bugs.php.net/bug.php?id=69233


--
Edit this bug report at https://bugs.php.net/bug.php?id=69233&edit=1


Thread (19 messages)

« previous php.bugs (#198938) next »