Bug #71821 [Opn]: php-fpm7 crashes due to unknown entry 'log_level' in config

From: Date: Mon, 14 Mar 2016 12:51:03 +0000
Subject: Bug #71821 [Opn]: php-fpm7 crashes due to unknown entry 'log_level' in config
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-199816@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=71821&edit=1 ID: 71821 User updated by: contact at sshilko dot com Reported by: contact at sshilko dot com Summary: php-fpm7 crashes due to unknown entry 'log_level' in config Status: Open Type: Bug Package: FPM related Operating System: Ubuntu 14.04.3 PHP Version: 7.0.4 Block user comment: N Private report: N New Comment: It's Amazon AWS EC2 instance ami-b82176d2 as a base (Ubuntu 14.04.03 LTS) ubuntu/images/ebs/ubuntu-trusty-14.04-amd64-server-20151218 - ami-b82176d2 Previous Comments: ------------------------------------------------------------------------ [2016-03-14 12:41:20] contact at sshilko dot com This is a clean system i'm installing via puppet/vagrant script. Only change i have is PHP version, i updated from 5.5 to 5.6 to 7.0.1-5+deb.sury.org~trusty+1 to 7.0.2-2+deb.sury.org~trusty+1 and now tried 7.0.4-5+deb.sury.org~trusty+1 but it failed immediattely due to log_level, after uncommenting it works. modules & info https://gist.github.com/sshilko/5dce14eccd90f43dea33 ------------------------------------------------------------------------ [2016-03-14 12:28:55] ondrej@php.net Sergei, what other modules do you have installed? Could you perhaps attach output of: php -r 'phpinfo();' I can't reproduce it with just php-fpm and neither with basic set of modules installed nor with full php7.0-* set of external modules as provided in the PPA. Re-running under valgrind also doesn't reveal anything suspicious. Correctly ends with: ``` [14-Mar-2016 12:26:22] ERROR: [/etc/php/7.0/fpm/php-fpm.conf:415] unknown entry 'log_level' [14-Mar-2016 12:26:22] ERROR: failed to load configuration file '/etc/php/7.0/fpm/php-fpm.conf' [14-Mar-2016 12:26:22] ERROR: FPM initialization failed [Inferior 1 (process 74801) exited with code 0116] ``` Any PECL modules (php-* packages)? Or anything under /usr/local? What does ldd /usr/sbin/php-fpm7.0 output? Can you reproduce this on clean system? (And if not, what's the difference between the two systems?) ------------------------------------------------------------------------ [2016-03-14 12:13:26] ondrej@php.net And that said script is just a simple wrapper around php-fpm -t: $ cat debian/php-fpm-checkconf #!/bin/sh set -e CONFFILE=${1:-/etc/php/@PHP_VERSION@/fpm/php-fpm.conf} errors=$(/usr/sbin/php-fpm@PHP_VERSION@ --fpm-config "$CONFFILE" -t 2>&1 | grep "\[ERROR\]" || true); if [ -n "$errors" ]; then echo "Please fix your configuration file..." echo $errors exit 1 fi exit 0 ------------------------------------------------------------------------ [2016-03-14 12:01:57] contact at sshilko dot com Description: ------------ $ /usr/lib/php/php7.0-fpm-checkconf Segmentation fault (core dumped) # gdb /usr/sbin/php-fpm7.0 GNU gdb (Ubuntu 7.7.1-0ubuntu5~14.04.2) 7.7.1 Copyright (C) 2014 Free Software Foundation, Inc. License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html> This is free software: you are free to change and redistribute it. There is NO WARRANTY, to the extent permitted by law. Type "show copying" and "show warranty" for details. This GDB was configured as "x86_64-linux-gnu". Type "show configuration" for configuration details. For bug reporting instructions, please see: <http://www.gnu.org/software/gdb/bugs/>. Find the GDB manual and other documentation resources online at: <http://www.gnu.org/software/gdb/documentation/>. For help, type "help". Type "apropos word" to search for commands related to "word"... Reading symbols from /usr/sbin/php-fpm7.0...(no debugging symbols found)...done. (gdb) run Starting program: /usr/sbin/php-fpm7.0 [Thread debugging using libthread_db enabled] Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1". [14-Mar-2016 11:56:02] ERROR: [/etc/php/7.0/fpm/php-fpm.conf:420] unknown entry 'log_level' [14-Mar-2016 11:56:02] ERROR: failed to load configuration file '/etc/php/7.0/fpm/php-fpm.conf' [14-Mar-2016 11:56:02] ERROR: FPM initialization failed zend_mm_heap corrupted [Inferior 1 (process 3842) exited with code 01] PHP 7.0.4-5+deb.sury.org~trusty+1 (cli) ( NTS ) Copyright (c) 1997-2016 The PHP Group Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies Test script: --------------- echo 'log_level=warning' >> /etc/php/7.0/fpm/php-fpm.conf $ /usr/lib/php/php7.0-fpm-checkconf Segmentation fault (core dumped) ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=71821&edit=1

« previous php.bugs (#199816) next »