Bug #71821 [Fbk->Opn]: php-fpm7 crashes due to unknown entry 'log_level' in config
| From: | contact at sshilko dot com | Date: | Tue, 15 Mar 2016 11:20:47 +0000 |
| Subject: | Bug #71821 [Fbk->Opn]: php-fpm7 crashes due to unknown entry 'log_level' in config | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-199835@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=71821&edit=1
ID: 71821
User updated by: contact at sshilko dot com
Reported by: contact at sshilko dot com
Summary: php-fpm7 crashes due to unknown entry 'log_level' in
config
-Status: Feedback
+Status: Open
Type: Bug
Package: FPM related
Operating System: Ubuntu 14.04.3
PHP Version: 7.0.4
Block user comment: N
Private report: N
New Comment:
Seems so, thanks Ondrej, i tested again
PHP 7.0.4-5+deb.sury.org~trusty+1
[11:15 AM]-[ubuntu]-[~]
$ sudo /usr/sbin/php-fpm7.0 -t; php -m |grep mongo
[15-Mar-2016 11:15:53] NOTICE: configuration file /etc/php/7.0/fpm/php-fpm.conf test is successful
zend_mm_heap corrupted
22:mongodb
[11:15 AM]-[ubuntu]-[~]
$ sudo /usr/sbin/php-fpm7.0 -t; php -m |grep mongo
[15-Mar-2016 11:15:54] NOTICE: configuration file /etc/php/7.0/fpm/php-fpm.conf test is successful
22:mongodb
its crashes every now and then with configtest,
$ sudo /usr/sbin/php-fpm7.0 -t
[15-Mar-2016 11:18:29] ERROR: [/etc/php/7.0/fpm/php-fpm.conf:421] unknown entry
'log_level'
[15-Mar-2016 11:18:29] ERROR: failed to load configuration file
'/etc/php/7.0/fpm/php-fpm.conf'
[15-Mar-2016 11:18:29] ERROR: FPM initialization failed
$ grep 'log_level' /etc/php/7.0/fpm/php-fpm.conf
42:;log_level = notice
127:log_level=notice
The issue that php-fpm doesnt like "log_level" is a separate issue by itself and randomly
crashes are caused by mongodb extension in
/usr/sbin/php-fpm7.0 -t
alho the main php-fpm process works fine with mongodb extension (i dont see segfaults in syslog for
past few days or so)
Previous Comments:
------------------------------------------------------------------------
[2016-03-15 11:06:22] ondrej@php.net
JFTR It's not caused by log_level=warning. That just makes PHP FPM to stop early.
I can reproduce the error with mongodb loaded on every php-fpm7.0 -t run.
root@lettie:~# php-fpm7.0 -t
[15-Mar-2016 11:04:16] NOTICE: configuration file /etc/php/7.0/fpm/php-fpm.conf test is successful
Segmentation fault (core dumped)
root@lettie:~# php-fpm7.0 -t
[15-Mar-2016 11:04:17] NOTICE: configuration file /etc/php/7.0/fpm/php-fpm.conf test is successful
zend_mm_heap corrupted
root@lettie:~#
------------------------------------------------------------------------
[2016-03-15 11:03:10] ondrej@php.net
I was able to reproduce it and it's a mongodb extension loaded that's causing the
segfault.
root@lettie:~# echo 'log_level=warning' >> /etc/php/7.0/fpm/php-fpm.conf
root@lettie:~# php-fpm7.0 -t
[15-Mar-2016 11:01:34] ERROR: [/etc/php/7.0/fpm/php-fpm.conf:415] unknown entry
'log_level'
[15-Mar-2016 11:01:34] ERROR: failed to load configuration file
'/etc/php/7.0/fpm/php-fpm.conf'
[15-Mar-2016 11:01:34] ERROR: FPM initialization failed
zend_mm_heap corrupted
root@lettie:~# phpdismod mongodb
root@lettie:~# php-fpm7.0 -t
[15-Mar-2016 11:01:41] ERROR: [/etc/php/7.0/fpm/php-fpm.conf:415] unknown entry
'log_level'
[15-Mar-2016 11:01:41] ERROR: failed to load configuration file
'/etc/php/7.0/fpm/php-fpm.conf'
[15-Mar-2016 11:01:41] ERROR: FPM initialization failed
root@lettie:~# phpenmod mongodb
root@lettie:~# php-fpm7.0 -t
[15-Mar-2016 11:01:47] ERROR: [/etc/php/7.0/fpm/php-fpm.conf:415] unknown entry
'log_level'
[15-Mar-2016 11:01:47] ERROR: failed to load configuration file
'/etc/php/7.0/fpm/php-fpm.conf'
[15-Mar-2016 11:01:47] ERROR: FPM initialization failed
Segmentation fault (core dumped)
I'll try to reproduce on Ubuntu Xenial, where I have dbgsym packages with debug symbols
available.
------------------------------------------------------------------------
[2016-03-15 09:23:23] laruence@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php
for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php
for Win32
Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.
I can not reproduce this.
------------------------------------------------------------------------
[2016-03-14 12:51:01] contact at sshilko dot com
It's Amazon AWS EC2 instance ami-b82176d2 as a base (Ubuntu 14.04.03 LTS)
ubuntu/images/ebs/ubuntu-trusty-14.04-amd64-server-20151218 - ami-b82176d2
------------------------------------------------------------------------
[2016-03-14 12:41:20] contact at sshilko dot com
This is a clean system i'm installing via puppet/vagrant script.
Only change i have is PHP version, i updated from 5.5 to 5.6 to 7.0.1-5+deb.sury.org~trusty+1 to
7.0.2-2+deb.sury.org~trusty+1 and now tried
7.0.4-5+deb.sury.org~trusty+1
but it failed immediattely due to log_level, after uncommenting it works.
modules & info
https://gist.github.com/sshilko/5dce14eccd90f43dea33
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=71821
--
Edit this bug report at https://bugs.php.net/bug.php?id=71821&edit=1