Bug #71821 [Com]: php-fpm7 crashes due to unknown entry 'log_level' in config

From: Date: Tue, 15 Mar 2016 11:06:24 +0000
Subject: Bug #71821 [Com]: php-fpm7 crashes due to unknown entry 'log_level' in config
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-199834@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=71821&edit=1 ID: 71821 Comment by: ondrej@php.net Reported by: contact at sshilko dot com Summary: php-fpm7 crashes due to unknown entry 'log_level' in config Status: Feedback Type: Bug Package: FPM related Operating System: Ubuntu 14.04.3 PHP Version: 7.0.4 Block user comment: N Private report: N New Comment: JFTR It's not caused by log_level=warning. That just makes PHP FPM to stop early. I can reproduce the error with mongodb loaded on every php-fpm7.0 -t run. root@lettie:~# php-fpm7.0 -t [15-Mar-2016 11:04:16] NOTICE: configuration file /etc/php/7.0/fpm/php-fpm.conf test is successful Segmentation fault (core dumped) root@lettie:~# php-fpm7.0 -t [15-Mar-2016 11:04:17] NOTICE: configuration file /etc/php/7.0/fpm/php-fpm.conf test is successful zend_mm_heap corrupted root@lettie:~# Previous Comments: ------------------------------------------------------------------------ [2016-03-15 11:03:10] ondrej@php.net I was able to reproduce it and it's a mongodb extension loaded that's causing the segfault. root@lettie:~# echo 'log_level=warning' >> /etc/php/7.0/fpm/php-fpm.conf root@lettie:~# php-fpm7.0 -t [15-Mar-2016 11:01:34] ERROR: [/etc/php/7.0/fpm/php-fpm.conf:415] unknown entry 'log_level' [15-Mar-2016 11:01:34] ERROR: failed to load configuration file '/etc/php/7.0/fpm/php-fpm.conf' [15-Mar-2016 11:01:34] ERROR: FPM initialization failed zend_mm_heap corrupted root@lettie:~# phpdismod mongodb root@lettie:~# php-fpm7.0 -t [15-Mar-2016 11:01:41] ERROR: [/etc/php/7.0/fpm/php-fpm.conf:415] unknown entry 'log_level' [15-Mar-2016 11:01:41] ERROR: failed to load configuration file '/etc/php/7.0/fpm/php-fpm.conf' [15-Mar-2016 11:01:41] ERROR: FPM initialization failed root@lettie:~# phpenmod mongodb root@lettie:~# php-fpm7.0 -t [15-Mar-2016 11:01:47] ERROR: [/etc/php/7.0/fpm/php-fpm.conf:415] unknown entry 'log_level' [15-Mar-2016 11:01:47] ERROR: failed to load configuration file '/etc/php/7.0/fpm/php-fpm.conf' [15-Mar-2016 11:01:47] ERROR: FPM initialization failed Segmentation fault (core dumped) I'll try to reproduce on Ubuntu Xenial, where I have dbgsym packages with debug symbols available. ------------------------------------------------------------------------ [2016-03-15 09:23:23] laruence@php.net Thank you for this bug report. To properly diagnose the problem, we need a backtrace to see what is happening behind the scenes. To find out how to generate a backtrace, please read http://bugs.php.net/bugs-generating-backtrace.php for *NIX and http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32 Once you have generated a backtrace, please submit it to this bug report and change the status back to "Open". Thank you for helping us make PHP better. I can not reproduce this. ------------------------------------------------------------------------ [2016-03-14 12:51:01] contact at sshilko dot com It's Amazon AWS EC2 instance ami-b82176d2 as a base (Ubuntu 14.04.03 LTS) ubuntu/images/ebs/ubuntu-trusty-14.04-amd64-server-20151218 - ami-b82176d2 ------------------------------------------------------------------------ [2016-03-14 12:41:20] contact at sshilko dot com This is a clean system i'm installing via puppet/vagrant script. Only change i have is PHP version, i updated from 5.5 to 5.6 to 7.0.1-5+deb.sury.org~trusty+1 to 7.0.2-2+deb.sury.org~trusty+1 and now tried 7.0.4-5+deb.sury.org~trusty+1 but it failed immediattely due to log_level, after uncommenting it works. modules & info https://gist.github.com/sshilko/5dce14eccd90f43dea33 ------------------------------------------------------------------------ [2016-03-14 12:28:55] ondrej@php.net Sergei, what other modules do you have installed? Could you perhaps attach output of: php -r 'phpinfo();' I can't reproduce it with just php-fpm and neither with basic set of modules installed nor with full php7.0-* set of external modules as provided in the PPA. Re-running under valgrind also doesn't reveal anything suspicious. Correctly ends with: ``` [14-Mar-2016 12:26:22] ERROR: [/etc/php/7.0/fpm/php-fpm.conf:415] unknown entry 'log_level' [14-Mar-2016 12:26:22] ERROR: failed to load configuration file '/etc/php/7.0/fpm/php-fpm.conf' [14-Mar-2016 12:26:22] ERROR: FPM initialization failed [Inferior 1 (process 74801) exited with code 0116] ``` Any PECL modules (php-* packages)? Or anything under /usr/local? What does ldd /usr/sbin/php-fpm7.0 output? Can you reproduce this on clean system? (And if not, what's the difference between the two systems?) ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at https://bugs.php.net/bug.php?id=71821 -- Edit this bug report at https://bugs.php.net/bug.php?id=71821&edit=1

« previous php.bugs (#199834) next »