#24199 [Opn->Fbk]: problem with loading module in apache 2.0.46
| From: | sniper@php.net | Date: | Mon, 16 Jun 2003 13:33:25 +0000 |
| Subject: | #24199 [Opn->Fbk]: problem with loading module in apache 2.0.46 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-42033@lists.php.net to get a copy of this message | ||
ID: 24199
Updated by: sniper@php.net
Reported By: keeper at fly dot srk dot fer dot hr
-Status: Open
+Status: Feedback
-Bug Type: Dynamic loading
+Bug Type: Apache2 related
Operating System: AIX
PHP Version: 4.3.2
New Comment:
And what might be in error_log about this..?
Previous Comments:
------------------------------------------------------------------------
[2003-06-16 02:54:48] keeper at fly dot srk dot fer dot hr
Description:
------------
I've compiled apache 2.0.46 with the following optins:
CPPFLAGS=-D_THREAD_SAFE ./configure --prefix=/stage/keeper/apache2 \
--enable-modules="headers info mime_magic rewrite so ssl status" \
--with-ssl=/usr/local/ssl \
--with-port=8080
The apache works just fine.
After that I've compiled php 4.3.2 with the following options:
./configure --prefix=/stage/keeper/php-4.3.2 \
--with-apxs2=/stage/keeper/apache2/bin/apxs \
--with-openssl=/usr/local/ssl
But after I try to start apache with added lines:
LoadModule php4_module modules/libphp4.so
AddType application/x-httpd-php .php
I get the following error:
Syntax error on line 233 of /stage/keeper/apache2/conf/httpd.conf:
Cannot load /stage/keeper/apache2/modules/libphp4.so into server:
It is weird because I've recently compiled the same apache+php on one
FreeBSD box and there was no problem.
Additional info:
OS: AIX 4330-09
compiler:gcc 2.95.3
openssl: 0.9.7b
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=24199&edit=1