#24199 [Opn->Fbk]: problem with loading module in apache 2.0.46

From: Date: Tue, 17 Jun 2003 10:44:10 +0000
Subject: #24199 [Opn->Fbk]: problem with loading module in apache 2.0.46
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-42118@lists.php.net to get a copy of this message
ID: 24199 Updated by: sniper@php.net Reported By: keeper at fly dot srk dot fer dot hr -Status: Open +Status: Feedback Bug Type: Apache2 related Operating System: AIX PHP Version: 4.3.2 New Comment: What does 'ldd libphp4.so' output? Previous Comments: ------------------------------------------------------------------------ [2003-06-17 04:58:17] keeper at fly dot srk dot fer dot hr gdb returns: (gdb) run -DONE_PROCESS Starting program: /stage/keeper/apache2/bin/httpd -DONE_PROCESS Syntax error on line 233 of /stage/keeper/apache2/conf/httpd.conf: Cannot load /stage/keeper/apache2/modules/libphp4.so into server: Program exited with code 01. (gdb) About duplicates in httpd.conf: there is no duplicates ------------------------------------------------------------------------ [2003-06-16 10:32:28] sniper@php.net Also make sure you don't have duplicate LoadModule for php4 in your httpd.conf ------------------------------------------------------------------------ [2003-06-16 10:31:28] sniper@php.net Try run it via gdb: # gdb httpd (gdb) run -DONE_PROCESS Maybe it crashes..? ------------------------------------------------------------------------ [2003-06-16 09:54:58] keeper at fly dot srk dot fer dot hr error_log file said nothing at all. It seems like I made a syntax error in conf file, which is very weird. Still: apachectl configtest return the same error: bash-2.05a$ /stage/keeper/apache2/bin/apachectl configtest Syntax error on line 233 of /stage/keeper/apache2/conf/httpd.conf: Cannot load /stage/keeper/apache2/modules/libphp4.so into server: Mario. ------------------------------------------------------------------------ [2003-06-16 08:33:24] sniper@php.net And what might be in error_log about this..? ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/24199 -- Edit this bug report at http://bugs.php.net/?id=24199&edit=1

« previous php.bugs (#42118) next »