#24199 [Fbk->Opn]: problem with loading module in apache 2.0.46
| From: | keeper at fly dot srk dot fer dot hr | Date: | Tue, 17 Jun 2003 09:58:19 +0000 |
| Subject: | #24199 [Fbk->Opn]: problem with loading module in apache 2.0.46 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-42111@lists.php.net to get a copy of this message | ||
ID: 24199
User updated by: keeper at fly dot srk dot fer dot hr
Reported By: keeper at fly dot srk dot fer dot hr
-Status: Feedback
+Status: Open
Bug Type: Apache2 related
Operating System: AIX
PHP Version: 4.3.2
New Comment:
gdb returns:
(gdb) run -DONE_PROCESS
Starting program: /stage/keeper/apache2/bin/httpd -DONE_PROCESS
Syntax error on line 233 of /stage/keeper/apache2/conf/httpd.conf:
Cannot load /stage/keeper/apache2/modules/libphp4.so into server:
Program exited with code 01.
(gdb)
About duplicates in httpd.conf: there is no duplicates
Previous Comments:
------------------------------------------------------------------------
[2003-06-16 10:32:28] sniper@php.net
Also make sure you don't have duplicate LoadModule for php4 in your
httpd.conf
------------------------------------------------------------------------
[2003-06-16 10:31:28] sniper@php.net
Try run it via gdb:
# gdb httpd
(gdb) run -DONE_PROCESS
Maybe it crashes..?
------------------------------------------------------------------------
[2003-06-16 09:54:58] keeper at fly dot srk dot fer dot hr
error_log file said nothing at all. It seems like I made a syntax error
in conf file, which is very weird.
Still: apachectl configtest return the same error:
bash-2.05a$ /stage/keeper/apache2/bin/apachectl configtest
Syntax error on line 233 of /stage/keeper/apache2/conf/httpd.conf:
Cannot load /stage/keeper/apache2/modules/libphp4.so into server:
Mario.
------------------------------------------------------------------------
[2003-06-16 08:33:24] sniper@php.net
And what might be in error_log about this..?
------------------------------------------------------------------------
[2003-06-16 02:54:48] keeper at fly dot srk dot fer dot hr
Description:
------------
I've compiled apache 2.0.46 with the following optins:
CPPFLAGS=-D_THREAD_SAFE ./configure --prefix=/stage/keeper/apache2 \
--enable-modules="headers info mime_magic rewrite so ssl status" \
--with-ssl=/usr/local/ssl \
--with-port=8080
The apache works just fine.
After that I've compiled php 4.3.2 with the following options:
./configure --prefix=/stage/keeper/php-4.3.2 \
--with-apxs2=/stage/keeper/apache2/bin/apxs \
--with-openssl=/usr/local/ssl
But after I try to start apache with added lines:
LoadModule php4_module modules/libphp4.so
AddType application/x-httpd-php .php
I get the following error:
Syntax error on line 233 of /stage/keeper/apache2/conf/httpd.conf:
Cannot load /stage/keeper/apache2/modules/libphp4.so into server:
It is weird because I've recently compiled the same apache+php on one
FreeBSD box and there was no problem.
Additional info:
OS: AIX 4330-09
compiler:gcc 2.95.3
openssl: 0.9.7b
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=24199&edit=1