#24416 [Com]: Apache2 won't start with PHP5 beta
| From: | aaron at gwmicro dot com | Date: | Tue, 01 Jul 2003 17:26:25 +0000 |
| Subject: | #24416 [Com]: Apache2 won't start with PHP5 beta | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-43006@lists.php.net to get a copy of this message | ||
ID: 24416
Comment by: aaron at gwmicro dot com
Reported By: ldf13 at hotmail dot com
Status: Bogus
Bug Type: Apache2 related
Operating System: Windows XP
PHP Version: 5CVS-2003-06-30 (dev)
New Comment:
I too had been having this problem. Turns out that running PHP from the
command line also yielded problems:
php.exe - Unable To Locate Component
This application has failed to start because iconv.dll was not found.
Re-installing the application may fix this problem.
Copying iconv.dll to the root of my PHP dir solved the problem. I also
topped it off with the latest snapshot as well, and am now successfully
running 5.0.0b2-dev with Apache 2.0.46.
I hope this helps someone, as trying to solve this problem was starting
to get a bit frustrating.
Aaron
Previous Comments:
------------------------------------------------------------------------
[2003-07-01 11:58:16] nuno at dbforums dot com
Yep, same thing here, Apache2.0.46, PHP5.0.0B1, and no matter what I do
I always get:
"Syntax error on line 169 of C:/Apache2/conf/httpd.conf:
Cannot load C:/Apache2/modules/php4apache2.dll into server: The
specified module could not be found"
I'm forced to conclude that PHP5 does not work with Windows :(
------------------------------------------------------------------------
[2003-06-30 12:16:58] sniper@php.net
php4_module -> php5_module
------------------------------------------------------------------------
[2003-06-30 12:04:25] ldf13 at hotmail dot com
Description:
------------
So far I could replace a PHP version by copying the .dll files to the
modules directory and that was it. This seems to be history in the PHP5
version because it won't start.
I am using Apache2.0.46 on WindowsXP with the binary set of PHP5 ..
Worst part is... no clue where to find some info on this.
Reproduce code:
---------------
these two lines are added to the httpd.conf file
LoadModule php4_module modules/php4apache2.dll
AddType application/x-httpd-php .php
and
php4apache2.dll & php4ts.dll
are copied to the modules directory
I do not use a php.ini file
Expected result:
----------------
a running webserver :) .. duh!
Actual result:
--------------
gives an error with no clue in the error file
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=24416&edit=1