#24416 [Com]: Apache2 won't start with PHP5 beta
| From: | nuno at dbforums dot com | Date: | Tue, 01 Jul 2003 18:37:54 +0000 |
| Subject: | #24416 [Com]: Apache2 won't start with PHP5 beta | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-43016@lists.php.net to get a copy of this message | ||
ID: 24416
Comment by: nuno at dbforums dot com
Reported By: ldf13 at hotmail dot com
Status: Bogus
Bug Type: Apache2 related
Operating System: Windows XP
PHP Version: 5CVS-2003-06-30 (dev)
New Comment:
Please forgive my ignorance but, how's that suppose to help?
[quote]
"Syntax error on line 169 of C:/Apache2/conf/httpd.conf:
Cannot load C:/Apache2/modules/php4apache2.dll into server: The
specified module could not be found"
[/quote]
Line 169: LoadModule php5_module modules/php4apache2.dll
Can you enlighten me further about this error and how to resolve it?
Thank you.
Previous Comments:
------------------------------------------------------------------------
[2003-07-01 13:24:36] sniper@php.net
See the error message Apache gives? Try READING it.
------------------------------------------------------------------------
[2003-07-01 13:22:58] nuno at dbforums dot com
You are correct, iconv.dll was in fact missing...but still no dice,
Apache 2.0.46 simply refuses to start.
Now testing with http://snaps.php.net/win32/php5-win32-latest.zip
and
nothing, same error message over and over again.
"Syntax error on line 169 of C:/Apache2/conf/httpd.conf:
Cannot load C:/Apache2/modules/php4apache2.dll into server: The
specified module could not be found"
SPECS:
OS: Win2K
Apache Ver: Apache 2.0.46
PHP Ver: php5-win32-latest
//httpd.conf
.
.
LoadModule php5_module c:/php/sapi/php4apache2.dll
AddType application/x-httpd-php .php
//
php.ini file in the C:/WINNT directory.
php4ts.dll file in the C:/WINNT/System32 directory.
php4apache2.dll is definitely in C:/php/sapi/
What am I missing? :(
------------------------------------------------------------------------
[2003-07-01 12:26:24] aaron at gwmicro dot com
I too had been having this problem. Turns out that running PHP from the
command line also yielded problems:
php.exe - Unable To Locate Component
This application has failed to start because iconv.dll was not found.
Re-installing the application may fix this problem.
Copying iconv.dll to the root of my PHP dir solved the problem. I also
topped it off with the latest snapshot as well, and am now successfully
running 5.0.0b2-dev with Apache 2.0.46.
I hope this helps someone, as trying to solve this problem was starting
to get a bit frustrating.
Aaron
------------------------------------------------------------------------
[2003-07-01 11:58:16] nuno at dbforums dot com
Yep, same thing here, Apache2.0.46, PHP5.0.0B1, and no matter what I do
I always get:
"Syntax error on line 169 of C:/Apache2/conf/httpd.conf:
Cannot load C:/Apache2/modules/php4apache2.dll into server: The
specified module could not be found"
I'm forced to conclude that PHP5 does not work with Windows :(
------------------------------------------------------------------------
[2003-06-30 12:16:58] sniper@php.net
php4_module -> php5_module
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/24416
--
Edit this bug report at http://bugs.php.net/?id=24416&edit=1