#24282 [Com]: Strange Open Base Dir Restriction Errors
| From: | dprado at floripa dot com dot br | Date: | Fri, 15 Aug 2003 14:52:49 +0000 |
| Subject: | #24282 [Com]: Strange Open Base Dir Restriction Errors | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-45969@lists.php.net to get a copy of this message | ||
ID: 24282
Comment by: dprado at floripa dot com dot br
Reported By: matzrek at shw-networks dot de
Status: Feedback
Bug Type: Apache related
Operating System: Suse Linux 8.2 / Apache 1.3.27
PHP Version: 4.3.3RC2
New Comment:
Samething happens here. PHP 4.3.2, the bug only shows randomly when
accessing virtualhosts that DO NOT have open_basedir set on a machine
that has other vhosts with open_basedir set. Taking a wild guess, it
seems that an apache thread that server up a page for a vhost with
openbasedir set when it tries to serve a page for another vhost
whithout openbasedir it keeps the openbasedir settings. Setting
open_basedir for all vhosts solved the problem.
Previous Comments:
------------------------------------------------------------------------
[2003-08-10 21:49:13] sniper@php.net
What we really need is that someone comes up with a complete testsuite
with which this problem can be reproduced reliably.
This would include the php.ini, httpd.conf, configure lines for
php/apache and a php script.
------------------------------------------------------------------------
[2003-08-07 07:20:12] chris at de-punkt dot de
Same problem here, random error just as in #19292. No open_basedir
defined at all. PHP4.3.2 and 4.3.3RC
------------------------------------------------------------------------
[2003-08-06 05:31:37] fs at nessus dot at
Hi!
I have tried this and i will report immediatly if the error occours
again.
I think its a good idea because of the Manual:
http://php.zend.com/manual/sk/printwn/configuration.changes.php
Greetings,
Florian Schicker
------------------------------------------------------------------------
[2003-08-05 11:17:30] sniper@php.net
Try this in the other vhosts:
php_admin_value open_basedir none
------------------------------------------------------------------------
[2003-08-05 11:10:58] matzrek at shw-networks dot de
Sorry : the latest 4.3.3RC2(!) also seens to contain this bug!
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/24282
--
Edit this bug report at http://bugs.php.net/?id=24282&edit=1