#24282 [Opn->Fbk]: Strange Open Base Dir Restriction Errors
| From: | sniper@php.net | Date: | Fri, 15 Aug 2003 16:07:33 +0000 |
| Subject: | #24282 [Opn->Fbk]: Strange Open Base Dir Restriction Errors | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-45976@lists.php.net to get a copy of this message | ||
ID: 24282
Updated by: sniper@php.net
Reported By: matzrek at shw-networks dot de
-Status: Open
+Status: Feedback
Bug Type: Apache related
Operating System: Suse Linux 8.2 / Apache 1.3.27
PHP Version: 4.3.2
New Comment:
I say again: We need to get the httpd.conf, etc. with which you HAVE
been experiencing this problem. Read my previous comment.
Previous Comments:
------------------------------------------------------------------------
[2003-08-15 10:48:00] matzrek at shw-networks dot de
Hi sniper,
This error cannot be reproduces exactly at the moment. It happens
sometimes. The only thin i realized : it does not appear directly after
restarting apache. I have to wait several hours until it happens the
first time.
Daniel
------------------------------------------------------------------------
[2003-08-15 09:52:48] dprado at floripa dot com dot br
Samething happens here. PHP 4.3.2, the bug only shows randomly when
accessing virtualhosts that DO NOT have open_basedir set on a machine
that has other vhosts with open_basedir set. Taking a wild guess, it
seems that an apache thread that server up a page for a vhost with
openbasedir set when it tries to serve a page for another vhost
whithout openbasedir it keeps the openbasedir settings. Setting
open_basedir for all vhosts solved the problem.
------------------------------------------------------------------------
[2003-08-10 21:49:13] sniper@php.net
What we really need is that someone comes up with a complete testsuite
with which this problem can be reproduced reliably.
This would include the php.ini, httpd.conf, configure lines for
php/apache and a php script.
------------------------------------------------------------------------
[2003-08-07 07:20:12] chris at de-punkt dot de
Same problem here, random error just as in #19292. No open_basedir
defined at all. PHP4.3.2 and 4.3.3RC
------------------------------------------------------------------------
[2003-08-06 05:31:37] fs at nessus dot at
Hi!
I have tried this and i will report immediatly if the error occours
again.
I think its a good idea because of the Manual:
http://php.zend.com/manual/sk/printwn/configuration.changes.php
Greetings,
Florian Schicker
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/24282
--
Edit this bug report at http://bugs.php.net/?id=24282&edit=1