#24282 [Com]: Strange Open Base Dir Restriction Errors

From: Date: Fri, 19 Sep 2003 08:13:06 +0000
Subject: #24282 [Com]: Strange Open Base Dir Restriction Errors
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-47819@lists.php.net to get a copy of this message
ID: 24282 Comment by: siminka at gmx dot de Reported By: matzrek at shw-networks dot de Status: Open Bug Type: Apache related Operating System: Suse Linux 8.2 / Apache 1.3.27 PHP Version: 4.3.2 New Comment: Same thing here with auto_prepend_file (Apache 2.0.47, PHP 4.3.3) - default httpd.conf and php-ini.dist. Two vhosts - <VirtualHost *:80> ServerName domain1.tld DocumentRoot /var/www/domain1.tld php_value auto_prepend_file global.php </VirtualHost> <VirtualHost *:80> ServerName domain2.tld DocumentRoot /var/www/domain2.tld </VirtualHost> ...one with auto_prepend_file, one without. Sometimes the auto_prepend_file of domain1.tld is prepended for the vhost of domain2.tld. When adding 'php_value auto_prepend_file none' to the domain2.tld vhost, the problem is gone. Really annoying bug! Previous Comments: ------------------------------------------------------------------------ [2003-08-26 00:43:14] red at raven dot ch seems to be the same or similar thing: bug #25198 I realised the same issue as dprado at floripa dot com dot br mentioned... ------------------------------------------------------------------------ [2003-08-15 11:07:33] sniper@php.net I say again: We need to get the httpd.conf, etc. with which you HAVE been experiencing this problem. Read my previous comment. ------------------------------------------------------------------------ [2003-08-15 09:52:48] dprado at floripa dot com dot br Samething happens here. PHP 4.3.2, the bug only shows randomly when accessing virtualhosts that DO NOT have open_basedir set on a machine that has other vhosts with open_basedir set. Taking a wild guess, it seems that an apache thread that server up a page for a vhost with openbasedir set when it tries to serve a page for another vhost whithout openbasedir it keeps the openbasedir settings. Setting open_basedir for all vhosts solved the problem. ------------------------------------------------------------------------ [2003-08-05 11:17:30] sniper@php.net Try this in the other vhosts: php_admin_value open_basedir none ------------------------------------------------------------------------ [2003-06-24 13:01:21] matzrek at shw-networks dot de the error happend at two different configurations : a) <VirtualHost 213.203.204.143> ServerAdmin webmaster@shw-network.de ServerName www.shw-network.de ServerAlias shw-network.de ServerAlias www.shw-networks.de ServerAlias shw-networks.de DocumentRoot /home/shw-network.de/htdocs ErrorLog /home/shw-network.de/log/error_log.log CustomLog /home/shw-network.de/log/access_log.log combined CustomLog /var/log/httpd/access_log.log combined </VirtualHost> an b ) <VirtualHost 213.203.204.143> ServerAdmin webmaster@shw-komplett.de DocumentRoot /home/cusomerdomain.de/htdocs/admin ServerName admin.cusomerdomain.de ServerAlias www.cusomerdomain.de ServerAlias cusomerdomain.de ErrorLog /home/cusomerdomain.de/log/error_log.log CustomLog /home/cusomerdomain.de/log/access_log.log combined CustomLog /var/log/httpd/access_log.log combined php_admin_flag safe_mode off php_admin_value open_base_dir "/home/cusomerdomain.de" php_admin_value safe_mode_exec_dir /bin </VirtualHost> if the error happens or not seems to depend on the apache process wich handles the request. The Apache uptime may also have some effect - it did not happen, directly after an apache restart. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/24282 -- Edit this bug report at http://bugs.php.net/?id=24282&edit=1

« previous php.bugs (#47819) next »