#26683 [NEW]: Apache Service Start Failure.
| From: | pawnup at yahoo dot com | Date: | Sat, 20 Dec 2003 23:28:20 +0000 |
| Subject: | #26683 [NEW]: Apache Service Start Failure. | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-52349@lists.php.net to get a copy of this message | ||
From: pawnup at yahoo dot com
Operating system: WinXP Home
PHP version: 5.0.0b2 (beta2)
PHP Bug Type: *Web Server problem
Bug description: Apache Service Start Failure.
Description:
------------
I was previously using php4.3.1 with apache 2.0.45 http server. I upgraded
Apache to 2.0.48 today and also upgraded PHP to 5.0.beta2.
I found that the apache service was unable to start. The system event log
showed error on line 177 of the httpd.conf file of apache. Actually, that
line is
LoadModule php4_module c:/php/sapi/php4apache2.dll
The problem seems to be in the php4apache2.dll file that came with
php5.0beta2.
Workaround: If I replace this dll with the older version that came with
php4.3.1 it works fine !. Although, this was a simple shortcut, this error
needs to be investigated further.
--
Edit bug report at http://bugs.php.net/?id=26683&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=26683&r=trysnapshot4
Try a CVS snapshot (php5): http://bugs.php.net/fix.php?id=26683&r=trysnapshot5
Fixed in CVS: http://bugs.php.net/fix.php?id=26683&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=26683&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=26683&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=26683&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=26683&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=26683&r=support
Expected behavior: http://bugs.php.net/fix.php?id=26683&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=26683&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=26683&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=26683&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=26683&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=26683&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=26683&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=26683&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=26683&r=float