#26683 [Com]: Apache Service Start Failure.
| From: | scottfurry at telusplanet dot net | Date: | Wed, 31 Dec 2003 09:41:16 +0000 |
| Subject: | #26683 [Com]: Apache Service Start Failure. | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-52630@lists.php.net to get a copy of this message | ||
ID: 26683
Comment by: scottfurry at telusplanet dot net
Reported By: pawnup at yahoo dot com
Status: Open
Bug Type: *Web Server problem
Operating System: WinXP Home
PHP Version: 5.0.0b2 (beta2)
New Comment:
I confirm this bug...
Previous:PHP4.3.4 UpgradePHP5.0beta3
Apache 2.0.48
Had modified PHP.ini to show both "LoadModule php4_..." and "LoadModule
php5_..." with the 5beta3 version of php4apache2.dll--> No Joy :(
As per "pawnup" 's observation (many thanks and kudos) I copied the
previous php4apache2.dll and modified the php.ini to show the file's
revision (i.e. "LoadModule php4_..."
Also copied all dll's in php folder to %\systemroot\%
And is phpinfo() not to reflect that its php5 installed?
cheers
Previous Comments:
------------------------------------------------------------------------
[2003-12-23 14:19:02] grzesiek at atlas dot cz
try
LoadModule php5_module c:/php/sapi/php4apache2.dll
------------------------------------------------------------------------
[2003-12-20 18:28:20] pawnup at yahoo dot com
Description:
------------
I was previously using php4.3.1 with apache 2.0.45 http server. I
upgraded Apache to 2.0.48 today and also upgraded PHP to 5.0.beta2.
I found that the apache service was unable to start. The system event
log showed error on line 177 of the httpd.conf file of apache.
Actually, that line is
LoadModule php4_module c:/php/sapi/php4apache2.dll
The problem seems to be in the php4apache2.dll file that came with
php5.0beta2.
Workaround: If I replace this dll with the older version that came with
php4.3.1 it works fine !. Although, this was a simple shortcut, this
error needs to be investigated further.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=26683&edit=1