#27372 [NEW]: parse error loading browscap.ini at apache startup
From: php-bug-NOSPAM-2004 at ryandesign dot com
Operating system: *
PHP version: 4CVS-2004-02-23 (stable)
PHP Bug Type: *General Issues
Bug description: parse error loading browscap.ini at apache startup
Description:
------------
When Apache starts with a new version of Gary Keith's
browscap.ini, PHP reports an error:
PHP: Error parsing /Library/WebServer/browscap.ini on
line 711
Line 711 reads:
browser=Yahoo! Slurp
Seems PHP's ini-file reading routine does not like the
bang in the browser name?
Reproduce code:
---------------
Download the 2/23/2004 or later browscap.ini (or download and unpack
browscap.zip) from www.garykeith.com.
Configure php.ini to point to this file.
Stop and restart Apache.
Expected result:
----------------
PHP should read in and accept the file without error.
Actual result:
--------------
PHP reports an error during Apache startup.
All browscap.ini entries before line 711 are loaded.
All entries after that are not.
Since browscap.ini is currently 18682 lines long, this
means most entries are not loaded.
--
Edit bug report at http://bugs.php.net/?id=27372&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=27372&r=trysnapshot4
Try a CVS snapshot (php5): http://bugs.php.net/fix.php?id=27372&r=trysnapshot5
Fixed in CVS: http://bugs.php.net/fix.php?id=27372&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=27372&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=27372&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=27372&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=27372&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=27372&r=support
Expected behavior: http://bugs.php.net/fix.php?id=27372&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=27372&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=27372&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=27372&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=27372&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=27372&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=27372&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=27372&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=27372&r=float
Thread (18 messages)
- php-bug-NOSPAM-2004 at ryandesign dot com
- php_bug_27372 at garykeith dot com#27372 [Com]: parse error loading browscap.ini at apache startup
- sniper@php.net#27372 [Opn->Ver]: parse error loading browscap.ini at apache startup
- php_bug_27372 at garykeith dot com#27372 [Com]: parse error loading browscap.ini at apache startup
- php_bug_27372 at garykeith dot com#27372 [Com]: parse error loading browscap.ini at apache startup
- sniper@php.net#27372 [Ver]: parse error loading browscap.ini at apache startup
- php_bug_27372 at garykeith dot com#27372 [Com]: parse error loading browscap.ini at apache startup
- php-bug-NOSPAM-2004 at ryandesign dot com#27372 [Ver]: parse error loading browscap.ini at apache startup
- php_bug_27372 at garykeith dot com#27372 [Com]: parse error loading browscap.ini at apache startup
- derick@php.net#27372 [Ver]: parse error loading browscap.ini at apache startup
- php_bug_27372 at garykeith dot com#27372 [Com]: parse error loading browscap.ini at apache startup
- jay@php.net#27372 [Ver]: parse error loading browscap.ini at apache startup (new parser required)
- alexandre at alapetite dot remove dot net#27372 [Com]: parse error loading browscap.ini at apache startup (new parser required)
- jay@php.net#27372 [Ver]: parse error loading browscap.ini at apache startup (new parser required)
- php-bug-27372 at ryandesign dot com#27372 [Ver]: parse error loading browscap.ini at apache startup (new parser required)
- nong11yjyygy at yahoo dot com#27372 [Com]: parse error loading browscap.ini at apache startup (new parser required)
- jani@php.net#27372 [Ver->Asn]: parse error loading browscap.ini at apache startup (new parser required)
- jani@php.net#27372 [Asn->Csd]: parse error loading browscap.ini at apache startup (new parser required)