#27372 [Opn->Ver]: parse error loading browscap.ini at apache startup

From: Date: Tue, 24 Feb 2004 09:25:40 +0000
Subject: #27372 [Opn->Ver]: parse error loading browscap.ini at apache startup
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-55436@lists.php.net to get a copy of this message
 ID:               27372
 Updated by:       sniper@php.net
 Reported By:      php-bug-NOSPAM-2004 at ryandesign dot com
-Status:           Open
+Status:           Verified
 Bug Type:         *General Issues
 Operating System: *
-PHP Version:      4CVS-2004-02-23 (stable)
+PHP Version:      4CVS, 5CVS (2004-02-24)
 New Comment:

Placing those values inside double quotes (") would fix it..
But as I guess that's not an option we have to fix the parser..for
php.ini, ! is special..

Maybe the best way to fix this is to have separate scanner/parser for
browscap.ini..



Previous Comments:
------------------------------------------------------------------------

[2004-02-23 20:26:01] php_bug_27372 at garykeith dot com

I have had 23 reports of this bug via the Bug Report form on my
website. Once again I'm taking the blame for bugs in get_browser().

~gary.

------------------------------------------------------------------------

[2004-02-23 17:22:22] php-bug-NOSPAM-2004 at ryandesign dot com

Description:
------------
When Apache starts with a new version of Gary Keith's 
browscap.ini, PHP reports an error:

PHP:  Error parsing /Library/WebServer/browscap.ini on 
line 711

Line 711 reads:

browser=Yahoo! Slurp

Seems PHP's ini-file reading routine does not like the 
bang in the browser name?

Reproduce code:
---------------
Download the 2/23/2004 or later browscap.ini (or download and unpack
browscap.zip) from www.garykeith.com.

Configure php.ini to point to this file.

Stop and restart Apache.

Expected result:
----------------
PHP should read in and accept the file without error.

Actual result:
--------------
PHP reports an error during Apache startup.

All browscap.ini entries before line 711 are loaded.

All entries after that are not.

Since browscap.ini is currently 18682 lines long, this 
means most entries are not loaded.


------------------------------------------------------------------------


-- 
Edit this bug report at http://bugs.php.net/?id=27372&edit=1


Thread (18 messages)

« previous php.bugs (#55436) next »