#27372 [Com]: parse error loading browscap.ini at apache startup

From: Date: Tue, 24 Feb 2004 16:14:34 +0000
Subject: #27372 [Com]: parse error loading browscap.ini at apache startup
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-55460@lists.php.net to get a copy of this message
 ID:               27372
 Comment by:       php_bug_27372 at garykeith dot com
 Reported By:      php-bug-NOSPAM-2004 at ryandesign dot com
 Status:           Verified
 Bug Type:         *General Issues
 Operating System: *
 PHP Version:      4CVS, 5CVS (2004-02-24)
 New Comment:

Oh, and the reason I cannot delimit certain values with double-quotes
is because browscap.dll does not strip out the quotes. If I entered
"Yahoo! Slurp" as a browser name then everyone using browscap.ini on
IIS would see "Yahoo! Slurp", including the double quotes as the
browser name.


Previous Comments:
------------------------------------------------------------------------

[2004-02-24 10:33:05] php_bug_27372 at garykeith dot com

I posted my comments here on Feb. 23, 2004 right after Ryan's initial
bug report. Now my comments are gone. And you know what? That's wrong.
All I did was confirm I've had 23 (as of this morning it's 37)
complaints about the same issue.

To me this is the last straw. I'm no longer willing to take the blame
for all of PHP's bugs. Please remove all references to my browscap.ini
file from your website. I will be posting a notice on my own website
announcing that my file is not recommended for PHP users.

Thanks for nearly three years of nothing but problems.

BTW, I would send this privately via e-mail but even after all these
years I do not know whom to contact at PHP.

~gary.

------------------------------------------------------------------------

[2004-02-24 04:25:40] sniper@php.net

Placing those values inside double quotes (") would fix it..
But as I guess that's not an option we have to fix the parser..for
php.ini, ! is special..

Maybe the best way to fix this is to have separate scanner/parser for
browscap.ini..


------------------------------------------------------------------------

[2004-02-23 17:22:22] php-bug-NOSPAM-2004 at ryandesign dot com

Description:
------------
When Apache starts with a new version of Gary Keith's 
browscap.ini, PHP reports an error:

PHP:  Error parsing /Library/WebServer/browscap.ini on 
line 711

Line 711 reads:

browser=Yahoo! Slurp

Seems PHP's ini-file reading routine does not like the 
bang in the browser name?

Reproduce code:
---------------
Download the 2/23/2004 or later browscap.ini (or download and unpack
browscap.zip) from www.garykeith.com.

Configure php.ini to point to this file.

Stop and restart Apache.

Expected result:
----------------
PHP should read in and accept the file without error.

Actual result:
--------------
PHP reports an error during Apache startup.

All browscap.ini entries before line 711 are loaded.

All entries after that are not.

Since browscap.ini is currently 18682 lines long, this 
means most entries are not loaded.


------------------------------------------------------------------------


-- 
Edit this bug report at http://bugs.php.net/?id=27372&edit=1


Thread (18 messages)

« previous php.bugs (#55460) next »