Bug #16748 Updated: Apache 2.0.36_dev fails to start after installingen PHP module
| From: | remy at planet dot nl | Date: | Wed, 24 Apr 2002 20:05:13 +0000 |
| Subject: | Bug #16748 Updated: Apache 2.0.36_dev fails to start after installingen PHP module | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-5877@lists.php.net to get a copy of this message | ||
ID: 16748
Updated by: remy@planet.nl
Reported By: remy@planet.nl
Status: Bogus
Bug Type: Apache2 related
Operating System: linux
PHP Version: 4.2.0
New Comment:
I've just compiled PHP with --enable-debug and PHP worked except the
cookies (mentioned in another bugreport).
Previous Comments:
------------------------------------------------------------------------
[2002-04-24 14:09:01] JuergenNagel@web.de
I also got the problem with Apache 2.0.35 not starting up when having
the PHP module activated.
I compiled PHP 4.2.0 with the following options:
--enable-safe-mode --enable-gd-native-ttf --enable-inline-optimization
--with-apxs2=/usr/apache2/bin/apxs --with-bz2 --with-zlib --with-cyrus
--with-dom --with-dom-xslt --with-gd=/usr/src/gd-2.0.1 --without-mysql
--with-pgsql=/opt/pgsql --prefix=/usr --with-openssl --enable-calendar
--enable-ftp --enable-gettext=shared --with-jpeg-dir=/usr
--with-png-dir=/usr --with-freetype-dir=/usr
The strange thing is, that there isn't any error message. Neither on
the console nor in the logfiles.
When I deactivate the PHP module the error_log says:
[Wed Apr 24 19:44:55 2002] [notice] suEXEC mechanism enabled (wrapper:
/usr/apache2/bin/suexec)
[Wed Apr 24 19:44:55 2002] [notice] Apache/2.0.35 (Unix) DAV/2
configured -- resuming normal operations
When I activate the PHP module the error_log says:
[Wed Apr 24 19:51:51 2002] [notice] suEXEC mechanism enabled (wrapper:
/usr/apache2/bin/suexec)
The Apache server just doesn't start.
Why? :-)
------------------------------------------------------------------------
[2002-04-23 06:59:20] mfischer@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php
If you can provide more information, feel free to add it
to this bug and change the status back to "Open".
------------------------------------------------------------------------
[2002-04-23 06:57:02] remy@planet.nl
I've tried to install PHP 4.2 and PHP 4.3_dev with Apache 2.0.36_dev.
But after the installation the PHP module will not start. One of the
stange things is, if I start apache without the PHP module and after
that I do a restart with the PHP module, the PHP module will work for a
park. Sessions will not work.
Remy Stibbe
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=16748&edit=1