#30366 [NEW]: xmlRelaxNGCleanupTypes: referenced symbol not found
| From: | dwaite at sun dot com | Date: | Fri, 08 Oct 2004 15:11:50 +0000 |
| Subject: | #30366 [NEW]: xmlRelaxNGCleanupTypes: referenced symbol not found | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-67294@lists.php.net to get a copy of this message | ||
From: dwaite at sun dot com
Operating system: Solaris 9 112233-12
PHP version: 5.0.2
PHP Bug Type: Apache related
Bug description: xmlRelaxNGCleanupTypes: referenced symbol not found
Description:
------------
I am running Solaris 9 112233-12 with dedault Apache. I have configured
and compiled PHP 5.0.2 with the following with no errors.
configure --with-mysql=/usr/local/mysql --with-apxs=/usr/apache/bin/apxs
--with-zlib --enable-bcmath --enable-calendar --enable-dbase --enable-exif
--enable-ftp --with-jpeg --with-png --with-tiff --with-gd --with-ttf
--enable-gd-native-ttf --with-gettext --with-iconv
--enable-mbstring=shared --enable-shmop --enable-sockets --enable-sysvmsg
--enable-sysvsem --enable-sysvshm --enable-memory-limit
Reproduce code:
---------------
httpd starting.
Syntax error on line 249 of /etc/apache/httpd.conf:
Cannot load /usr/apache/libexec/libphp5.so into server: ld.so.1:
/usr/apache/bin/httpd: fatal: relocation error: file
/usr/apache/libexec/libphp5.so: symbol xmlRelaxNGCleanupTypes: referenced
symbol not found
/usr/apache/bin/apachectl start: httpd could not be started
It appears as though there is an libxml or libxml2 undefined symbol. Any
Idea why this is happening.
Thanks,
Dave
--
Edit bug report at http://bugs.php.net/?id=30366&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=30366&r=trysnapshot4
Try a CVS snapshot (php5.0): http://bugs.php.net/fix.php?id=30366&r=trysnapshot50
Try a CVS snapshot (php5.1): http://bugs.php.net/fix.php?id=30366&r=trysnapshot51
Fixed in CVS: http://bugs.php.net/fix.php?id=30366&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=30366&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=30366&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=30366&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=30366&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=30366&r=support
Expected behavior: http://bugs.php.net/fix.php?id=30366&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=30366&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=30366&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=30366&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=30366&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=30366&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=30366&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=30366&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=30366&r=float
MySQL Configuration Error: http://bugs.php.net/fix.php?id=30366&r=mysqlcfg