#30366 [Fbk->Opn]: xmlRelaxNGCleanupTypes: referenced symbol not found

From: Date: Mon, 11 Oct 2004 14:18:16 +0000
Subject: #30366 [Fbk->Opn]: xmlRelaxNGCleanupTypes: referenced symbol not found
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-67414@lists.php.net to get a copy of this message
ID: 30366 User updated by: dwaite at sun dot com Reported By: dwaite at sun dot com -Status: Feedback +Status: Open Bug Type: DOM XML related Operating System: Solaris 9 112233-12 PHP Version: 5.0.2 New Comment: After going in and removing any previous versions of libxml2 Apache will start without an error. Maybe it should be noted in the PHP docs even though this is not realy PHP related that only one version of libxml2 can exist so delete all others. Thanks, Dave Previous Comments: ------------------------------------------------------------------------ [2004-10-11 08:26:59] chregu@php.net Recategorize (still not sure, if it's a PHP problem, but if it's one, then it's dom/libxml2 related) ------------------------------------------------------------------------ [2004-10-09 10:51:44] chregu@php.net Can you please check, if RelaxNG support is enabled in your libxml2? You can check this, if you do "xmllint --help" and see, if there's a relaxng option. Furthermore make sure, you don't have old libxml2 versions lying around elsewhere, which are maybe taken by php. ------------------------------------------------------------------------ [2004-10-08 23:34:32] ranglin at jamdung dot com I am having same issues: Sol 9, php 5.0x, apache 205. libxml2-2.6.4 Cannot load /usr/local/apache/modules/libphp5.so into server: ld.so.1: /usr/local/apache/bin/httpd: fatal: relocation error: file /usr/local/apache/modules/libphp5.so: symbol xmlRelaxNGCleanupTypes: referenced symbol not found ------------------------------------------------------------------------ [2004-10-08 17:35:22] dwaite at sun dot com This is the verson, libxml2-2.6.8 which I believe is the lates. An interesting note that if I configure with only --with-mysql=/usr/local/mysql --with-apxs=/usr/apache/bin/apxs I get a make install failure that is similar. Dave ------------------------------------------------------------------------ [2004-10-08 17:22:32] chregu@php.net which libxml2 version are you using? Does this also happen with a recent one? ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/30366 -- Edit this bug report at http://bugs.php.net/?id=30366&edit=1

« previous php.bugs (#67414) next »