#30366 [Fbk->Opn]: xmlRelaxNGCleanupTypes: referenced symbol not found
| From: | dwaite at sun dot com | Date: | Fri, 08 Oct 2004 15:35:28 +0000 |
| Subject: | #30366 [Fbk->Opn]: xmlRelaxNGCleanupTypes: referenced symbol not found | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-67303@lists.php.net to get a copy of this message | ||
ID: 30366
User updated by: dwaite at sun dot com
Reported By: dwaite at sun dot com
-Status: Feedback
+Status: Open
Bug Type: Apache related
Operating System: Solaris 9 112233-12
PHP Version: 5.0.2
New Comment:
This is the verson, libxml2-2.6.8 which I believe is the lates. An
interesting note that if I configure with only
--with-mysql=/usr/local/mysql --with-apxs=/usr/apache/bin/apxs I get a
make install failure that is similar.
Dave
Previous Comments:
------------------------------------------------------------------------
[2004-10-08 17:22:32] chregu@php.net
which libxml2 version are you using? Does this also happen with a
recent one?
------------------------------------------------------------------------
[2004-10-08 17:11:46] dwaite at sun dot com
Description:
------------
I am running Solaris 9 112233-12 with dedault Apache. I have configured
and compiled PHP 5.0.2 with the following with no errors.
configure --with-mysql=/usr/local/mysql
--with-apxs=/usr/apache/bin/apxs --with-zlib --enable-bcmath
--enable-calendar --enable-dbase --enable-exif --enable-ftp --with-jpeg
--with-png --with-tiff --with-gd --with-ttf --enable-gd-native-ttf
--with-gettext --with-iconv --enable-mbstring=shared --enable-shmop
--enable-sockets --enable-sysvmsg --enable-sysvsem --enable-sysvshm
--enable-memory-limit
Reproduce code:
---------------
httpd starting.
Syntax error on line 249 of /etc/apache/httpd.conf:
Cannot load /usr/apache/libexec/libphp5.so into server: ld.so.1:
/usr/apache/bin/httpd: fatal: relocation error: file
/usr/apache/libexec/libphp5.so: symbol xmlRelaxNGCleanupTypes:
referenced symbol not found
/usr/apache/bin/apachectl start: httpd could not be started
It appears as though there is an libxml or libxml2 undefined symbol.
Any Idea why this is happening.
Thanks,
Dave
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=30366&edit=1