#32067 [NEW]: DSO problems
| From: | j dot lammerts at chello dot nl | Date: | Tue, 22 Feb 2005 15:14:15 +0000 |
| Subject: | #32067 [NEW]: DSO problems | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-74425@lists.php.net to get a copy of this message | ||
From: j dot lammerts at chello dot nl
Operating system: AIX 5.2
PHP version: 4CVS-2005-02-22 (stable)
PHP Bug Type: *Configuration Issues
Bug description: DSO problems
Description:
------------
Hi,
I seem to be unable to get the latetst stable php4 to compile.
I'm using AIX 5.2 and IBM HTTPServer 2.0.47.1
If I try to configure with --apxs=/usr/IBMIHS/bin/apxs
I get the message :
Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS... expr:
non-numeric argument
yes
Then, at the end :
WARNING: Your /usr/IBMIHS/bin/apxs script is most likely broken.
If I try to configure with --apxs2=/usr/IBMIHS/bin/apxs
I get the message:
checking for Apache 2.0 filter-module support via DSO through APXS... no
checking for Apache 2.0 handler-module support via DSO through APXS...
expr: non-numeric a
rgument
configure: error: You have enabled Apache 2 support while your server is
Apache 1.3. Plea
se use the appropiate switch --with-apxs (without the 2)
(although I'm using 2.0.47.1 ??)
Is this due to the fact that IBM messes around with standard Apache
configs, and makes up their own apxs ?
Cheers
--
Edit bug report at http://bugs.php.net/?id=32067&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=32067&r=trysnapshot4
Try a CVS snapshot (php5.0): http://bugs.php.net/fix.php?id=32067&r=trysnapshot50
Try a CVS snapshot (php5.1): http://bugs.php.net/fix.php?id=32067&r=trysnapshot51
Fixed in CVS: http://bugs.php.net/fix.php?id=32067&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=32067&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=32067&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=32067&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=32067&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=32067&r=support
Expected behavior: http://bugs.php.net/fix.php?id=32067&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=32067&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=32067&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=32067&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=32067&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=32067&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=32067&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=32067&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=32067&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=32067&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=32067&r=mysqlcfg