#32067 [Opn->Fbk]: DSO problems
| From: | derick@php.net | Date: | Tue, 22 Feb 2005 22:09:29 +0000 |
| Subject: | #32067 [Opn->Fbk]: DSO problems | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-74436@lists.php.net to get a copy of this message | ||
ID: 32067
Updated by: derick@php.net
Reported By: j dot lammerts at chello dot nl
-Status: Open
+Status: Feedback
Bug Type: *Configuration Issues
Operating System: AIX 5.2
PHP Version: 4CVS-2005-02-22 (stable)
New Comment:
It's most likely because their version string has a different format,
please put the config.log online and provide a link to it here.
Previous Comments:
------------------------------------------------------------------------
[2005-02-22 16:14:15] j dot lammerts at chello dot nl
Description:
------------
Hi,
I seem to be unable to get the latetst stable php4 to compile.
I'm using AIX 5.2 and IBM HTTPServer 2.0.47.1
If I try to configure with --apxs=/usr/IBMIHS/bin/apxs
I get the message :
Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS... expr:
non-numeric argument
yes
Then, at the end :
WARNING: Your /usr/IBMIHS/bin/apxs script is most likely broken.
If I try to configure with --apxs2=/usr/IBMIHS/bin/apxs
I get the message:
checking for Apache 2.0 filter-module support via DSO through APXS...
no
checking for Apache 2.0 handler-module support via DSO through APXS...
expr: non-numeric a
rgument
configure: error: You have enabled Apache 2 support while your server
is Apache 1.3. Plea
se use the appropiate switch --with-apxs (without the 2)
(although I'm using 2.0.47.1 ??)
Is this due to the fact that IBM messes around with standard Apache
configs, and makes up their own apxs ?
Cheers
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=32067&edit=1