#32067 [WFx]: DSO problems

From: Date: Mon, 28 Feb 2005 15:59:03 +0000
Subject: #32067 [WFx]: DSO problems
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-74688@lists.php.net to get a copy of this message
ID: 32067 User updated by: j dot lammerts at chello dot nl Reported By: j dot lammerts at chello dot nl Status: Wont fix Bug Type: Apache2 related Operating System: AIX 5.2 PHP Version: 4CVS-2005-02-22 (stable) New Comment: Hmm, bummer. What if I'm bound to IBM's version of Apache2 ? I'm using IBMIHS 2.0.47.1 in a professional environment and cannot decide to switch from IHS to the original Apache2. Same question as before: is this behaviour due to the fact that IBM messes around with the Apache sources, and does this mean that I will not be able to use PHP with IBM HTTPServer, ever ? Thanks for the support so far. Previous Comments: ------------------------------------------------------------------------ [2005-02-28 13:34:51] sniper@php.net Your system does not have pthreads -> ZTS only supports them. (like the error msg says) Get Apache2 from apache.org and compile it _without_ thread support and try again. See also: http://www.php.net/manual/en/install.unix.apache2.php ------------------------------------------------------------------------ [2005-02-28 09:48:39] j dot lammerts at chello dot nl Ok, here's the output: (Went wrong first, because default /usr/IBMIHS/lib was not in LIBPATH environment): fvlsaa1 /usr/IBMIHS # httpd=`/usr/IBMIHS/bin/apxs -q SBINDIR//usr/IBMIHS/bin/apx> fvlsaa1 /usr/IBMIHS # $httpd -v 2>&1 | grep version fvlsaa1 /usr/IBMIHS # $httpd -v exec(): 0509-036 Cannot load program /usr/IBMIHS/bin/httpd because of the following errors : 0509-150 Dependent module libaprutil-0.so could not be loaded. 0509-022 Cannot load module libaprutil-0.so. 0509-026 System error: A file or directory in the path name does not exist. fvlsaa1 /usr/IBMIHS # export LIBPATH=$LIBPATH:/usr/IBMIHS/lib fvlsaa1 /usr/IBMIHS # $httpd -v Server version: IBM_HTTP_Server/2.0.47.1 Apache/2.0.47 Server built: May 20 2004 17:07:49 fvlsaa1 /usr/IBMIHS # $httpd -v 2>&1 | grep version Server version: IBM_HTTP_Server/2.0.47.1 Apache/2.0.47 Tried configure again, with --with-apxs2, producing this result: checking for Apache 2.0 filter-module support via DSO through APXS... no checking for Apache 2.0 handler-module support via DSO through APXS... configure: error: Z TS currently requires working POSIX threads. We were unable to verify that your system sup ports Pthreads. ------------------------------------------------------------------------ [2005-02-27 23:32:37] sniper@php.net Just provide the output of this set of commands: # httpd=/usr/IBMIHS/bin/apxs -q SBINDIR/`/usr/IBMIHS/bin/apxs -q TARGET` # $httpd -v 2>&1 | grep version # $httpd -v ------------------------------------------------------------------------ [2005-02-27 15:51:57] j dot lammerts at chello dot nl Will put up a link to this file. Please give me a bit to re-setup my webserver. Will have it ready by the end of this month. ------------------------------------------------------------------------ [2005-02-22 23:09:27] derick@php.net It's most likely because their version string has a different format, please put the config.log online and provide a link to it here. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/32067 -- Edit this bug report at http://bugs.php.net/?id=32067&edit=1

« previous php.bugs (#74688) next »