#35385 [Fbk]: libphp5.so fails to load

From: Date: Fri, 25 Nov 2005 12:42:13 +0000
Subject: #35385 [Fbk]: libphp5.so fails to load
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-88952@lists.php.net to get a copy of this message
 ID:               35385
 Updated by:       tony2001@php.net
 Reported By:      yg at mind dot lu
 Status:           Feedback
 Bug Type:         IMAP related
 Operating System: Linux (Debian sarge)
 PHP Version:      5.1.0
 New Comment:

If you copy ext/imap folder from the older version over the new one and
run ./buildconf --force && ./configure ... && make - does this fix the
problem?


Previous Comments:
------------------------------------------------------------------------

[2005-11-25 13:39:05] jens dot jacobsen at web dot de

I can confirm this for me. PHP 5.1 with IMAP compiled in causes apache
to fail at start with the following message:

Starting httpd2 (prefork) Syntax error on line 27 of
/etc/apache2/sysconfig.d/loadmodule.conf:
Cannot load /usr/lib/apache2/libphp5.so into server:
/usr/lib/libc-client.so: undefined symbol: mm_dlog

PHP 5.0.5 compiled with the same configure causes no fail on apache
start.

------------------------------------------------------------------------

[2005-11-25 13:34:59] rick at schippersnet dot nl

I didn't change anything. I just recompiled php 5.0.5 after php 5.1.0
failed, with the exact same configure options, that works fine. php
5.1.0 won't load with imap enabled.

------------------------------------------------------------------------

[2005-11-25 12:53:46] tony2001@php.net

>The PHP 5.0.5 source works fine with the same libc-client.
What did you change since then?
GCC version? Anything else?

------------------------------------------------------------------------

[2005-11-25 11:41:37] rick at schippersnet dot nl

Same thing happens here. Debian sarge also with apache2-mpm-prefork. 

The PHP 5.0.5 source works fine with the same libc-client.

------------------------------------------------------------------------

[2005-11-25 11:37:53] yg at mind dot lu

Thanks for your answer.

It's the following two lines:
--with-imap
--with-imap-ssl

Without them it loads fine. As soon as I add them, I get the
mentioned error when apache wants to load libphp5.so.

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
    http://bugs.php.net/35385

-- 
Edit this bug report at http://bugs.php.net/?id=35385&edit=1


Thread (18 messages)

« previous php.bugs (#88952) next »