#35385 [NEW]: libphp5.so fails to load

From: Date: Fri, 25 Nov 2005 08:57:20 +0000
Subject: #35385 [NEW]: libphp5.so fails to load
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-88907@lists.php.net to get a copy of this message
From: yg at mind dot lu Operating system: Linux (Debian sarge) PHP version: 5.1.0 PHP Bug Type: IMAP related Bug description: libphp5.so fails to load Description: ------------ If you compile php5.1 with imap support, it compiles fine but fails to load into apache2 with a somboly error, the exact errormessage is here: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/libc-client.so.2002edebian: undefined symbol: mm_dlog I am using debian sarge which has apache 2.0.54 There is already a bug about that problem, and the distro (gentoo) is blamed, my distro is another, so maybe the problem might me more general as distro-specific http://bugs.php.net/bug.php?id=33630 php compilation has been configured that way: ./configure \ --disable-debug \ --with-apxs2=/usr/bin/apxs2 \ --prefix=/usr/local/php51_apache2 \ --with-interbase=/usr/lib/firebird2 \ --with-mysql \ --with-mysqli \ --enable-gd-native-ttf \ --enable-gd-imgstrttf \ --with-freetype-dir \ --with-ttf=/usr \ --with-zlib \ --with-png-dir \ --with-jpeg-dir \ --with-pdflib \ --enable-ftp \ --enable-bcmath \ --enable-calendar \ --enable-memory-limit \ --enable-libgcc \ --enable-inline-optimization \ --with-gd \ --enable-mbstring \ --enable-dbase \ --enable-versioning \ --enable-dio \ --enable-ftp \ --enable-sqlite-utf8 \ --with-xmlrpc \ --with-pdo-firebird \ --with-pdo-mysql \ --with-pdo-sqlite \ --disable-cli \ --disable-cgi \ --with-config-file-path=/etc/php5.1 \ --with-openssl \ --with-bz2 \ --with-ldap \ --with-sqlite=/usr \ --with-imap=/usr \ --with-imap-ssl=/usr \ --with-kerberos -- Edit bug report at http://bugs.php.net/?id=35385&edit=1 -- Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=35385&r=trysnapshot4 Try a CVS snapshot (php5.0): http://bugs.php.net/fix.php?id=35385&r=trysnapshot50 Try a CVS snapshot (php5.1): http://bugs.php.net/fix.php?id=35385&r=trysnapshot51 Fixed in CVS: http://bugs.php.net/fix.php?id=35385&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=35385&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=35385&r=needtrace Need Reproduce Script: http://bugs.php.net/fix.php?id=35385&r=needscript Try newer version: http://bugs.php.net/fix.php?id=35385&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=35385&r=support Expected behavior: http://bugs.php.net/fix.php?id=35385&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=35385&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=35385&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=35385&r=globals PHP 3 support discontinued: http://bugs.php.net/fix.php?id=35385&r=php3 Daylight Savings: http://bugs.php.net/fix.php?id=35385&r=dst IIS Stability: http://bugs.php.net/fix.php?id=35385&r=isapi Install GNU Sed: http://bugs.php.net/fix.php?id=35385&r=gnused Floating point limitations: http://bugs.php.net/fix.php?id=35385&r=float No Zend Extensions: http://bugs.php.net/fix.php?id=35385&r=nozend MySQL Configuration Error: http://bugs.php.net/fix.php?id=35385&r=mysqlcfg

« previous php.bugs (#88907) next »