#35385 [Opn]: libphp5.so fails to load
| From: | yg at mind dot lu | Date: | Fri, 25 Nov 2005 09:19:56 +0000 |
| Subject: | #35385 [Opn]: libphp5.so fails to load | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-88909@lists.php.net to get a copy of this message | ||
ID: 35385
User updated by: yg at mind dot lu
Reported By: yg at mind dot lu
Status: Open
Bug Type: IMAP related
Operating System: Linux (Debian sarge)
PHP Version: 5.1.0
New Comment:
I tried to build imap as a shared module, and it also fails
to load with the following error:
Warning: dl() [function.dl.html]: Invalid library (maybe not a PHP
library) 'imap.so' in /home/yves/public_html/phpinfo.php on line 3
Previous Comments:
------------------------------------------------------------------------
[2005-11-25 09:57:18] yg at mind dot lu
Description:
------------
If you compile php5.1 with imap support, it compiles fine
but fails to load into apache2 with a somboly error, the
exact errormessage is here:
Cannot load /usr/lib/apache2/modules/libphp5.so into server:
/usr/lib/libc-client.so.2002edebian: undefined symbol: mm_dlog
I am using debian sarge which has apache 2.0.54
There is already a bug about that problem, and the
distro (gentoo) is blamed, my distro is another, so maybe
the problem might me more general as distro-specific
http://bugs.php.net/bug.php?id=33630
php compilation has been configured that way:
./configure \
--disable-debug \
--with-apxs2=/usr/bin/apxs2 \
--prefix=/usr/local/php51_apache2 \
--with-interbase=/usr/lib/firebird2 \
--with-mysql \
--with-mysqli \
--enable-gd-native-ttf \
--enable-gd-imgstrttf \
--with-freetype-dir \
--with-ttf=/usr \
--with-zlib \
--with-png-dir \
--with-jpeg-dir \
--with-pdflib \
--enable-ftp \
--enable-bcmath \
--enable-calendar \
--enable-memory-limit \
--enable-libgcc \
--enable-inline-optimization \
--with-gd \
--enable-mbstring \
--enable-dbase \
--enable-versioning \
--enable-dio \
--enable-ftp \
--enable-sqlite-utf8 \
--with-xmlrpc \
--with-pdo-firebird \
--with-pdo-mysql \
--with-pdo-sqlite \
--disable-cli \
--disable-cgi \
--with-config-file-path=/etc/php5.1 \
--with-openssl \
--with-bz2 \
--with-ldap \
--with-sqlite=/usr \
--with-imap=/usr \
--with-imap-ssl=/usr \
--with-kerberos
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=35385&edit=1